<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-77928330-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-77928330-1');
</script>

<link rel="stylesheet" id="wp-forecast-css" href="https://www.palestinechronicle.com/wp-content/plugins/wp-forecast/wp-forecast-default.css" type="text/css" media="screen" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v17.8 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>‘We Will Not Forget’: Palestinians Commemorate Land Day in Gaza (PHOTOS) - Palestine Chronicle</title>
	<meta name="description" content="Palestinians in Gaza participated in a rally marking the 46th anniversary of Palestinian Land Day near the fishermen&#039;s port in Gaza City." />
	<link rel="canonical" href="https://www.palestinechronicle.com/we-will-not-forget-palestinians-commemorate-land-day-in-gaza-photos/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="‘We Will Not Forget’: Palestinians Commemorate Land Day in Gaza (PHOTOS)" />
	<meta property="og:description" content="Palestinians in Gaza participated in a rally marking the 46th anniversary of Palestinian Land Day near the fishermen&#039;s port in Gaza City." />
	<meta property="og:url" content="https://www.palestinechronicle.com/we-will-not-forget-palestinians-commemorate-land-day-in-gaza-photos/" />
	<meta property="og:site_name" content="Palestine Chronicle" />
	<meta property="article:publisher" content="https://www.facebook.com/pages/The-Palestine-Chronicle-PalestineChroniclecom/302592203117857?ref=ts&amp;amp%3bamp%3bfref=ts" />
	<meta property="article:published_time" content="2022-03-30T18:59:46+00:00" />
	<meta property="article:modified_time" content="2022-03-30T19:00:36+00:00" />
	<meta property="og:image" content="https://www.palestinechronicle.com/wp-content/uploads/2022/03/Land-Day2.png" />
	<meta property="og:image:width" content="678" />
	<meta property="og:image:height" content="455" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="admin" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="6 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.palestinechronicle.com/#website","url":"https://www.palestinechronicle.com/","name":"Palestine Chronicle","description":"NEWS &amp; VIEWS FROM PALESTINE AND THE MIDDLE EAST","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.palestinechronicle.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.palestinechronicle.com/we-will-not-forget-palestinians-commemorate-land-day-in-gaza-photos/#primaryimage","inLanguage":"en-US","url":"https://www.palestinechronicle.com/wp-content/uploads/2022/03/Land-Day2.png","contentUrl":"https://www.palestinechronicle.com/wp-content/uploads/2022/03/Land-Day2.png","width":678,"height":455,"caption":"Palestinians commemorate Land Day in Gaza. (Photo: Mahmoud Ajjour, The Palestine Chronicle)"},{"@type":"WebPage","@id":"https://www.palestinechronicle.com/we-will-not-forget-palestinians-commemorate-land-day-in-gaza-photos/#webpage","url":"https://www.palestinechronicle.com/we-will-not-forget-palestinians-commemorate-land-day-in-gaza-photos/","name":"\u2018We Will Not Forget\u2019: Palestinians Commemorate Land Day in Gaza (PHOTOS) - Palestine Chronicle","isPartOf":{"@id":"https://www.palestinechronicle.com/#website"},"primaryImageOfPage":{"@id":"https://www.palestinechronicle.com/we-will-not-forget-palestinians-commemorate-land-day-in-gaza-photos/#primaryimage"},"datePublished":"2022-03-30T18:59:46+00:00","dateModified":"2022-03-30T19:00:36+00:00","author":{"@id":"https://www.palestinechronicle.com/#/schema/person/6876d6312c6aa18882ca63366a7b5926"},"description":"Palestinians in Gaza participated in a rally marking the 46th anniversary of Palestinian Land Day near the fishermen's port in Gaza City.","breadcrumb":{"@id":"https://www.palestinechronicle.com/we-will-not-forget-palestinians-commemorate-land-day-in-gaza-photos/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.palestinechronicle.com/we-will-not-forget-palestinians-commemorate-land-day-in-gaza-photos/"]}]},{"@type":"BreadcrumbList","@id":"https://www.palestinechronicle.com/we-will-not-forget-palestinians-commemorate-land-day-in-gaza-photos/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.palestinechronicle.com/"},{"@type":"ListItem","position":2,"name":"Articles","item":"https://www.palestinechronicle.com/category/articles/"},{"@type":"ListItem","position":3,"name":"\u2018We Will Not Forget\u2019: Palestinians Commemorate Land Day in Gaza (PHOTOS)"}]},{"@type":"Person","@id":"https://www.palestinechronicle.com/#/schema/person/6876d6312c6aa18882ca63366a7b5926","name":"admin","url":"https://www.palestinechronicle.com/author/admin/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//www.palestinechronicle.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Palestine Chronicle &raquo; Feed" href="https://www.palestinechronicle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Palestine Chronicle &raquo; Comments Feed" href="https://www.palestinechronicle.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Palestine Chronicle &raquo; ‘We Will Not Forget’: Palestinians Commemorate Land Day in Gaza (PHOTOS) Comments Feed" href="https://www.palestinechronicle.com/we-will-not-forget-palestinians-commemorate-land-day-in-gaza-photos/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.palestinechronicle.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.4"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='cptch_stylesheet-css'  href='https://www.palestinechronicle.com/wp-content/plugins/captcha/css/front_end_style.css?ver=4.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.palestinechronicle.com/wp-includes/css/dashicons.min.css?ver=5.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='cptch_desktop_style-css'  href='https://www.palestinechronicle.com/wp-content/plugins/captcha/css/desktop_style.css?ver=4.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='super-rss-reader-css'  href='https://www.palestinechronicle.com/wp-content/plugins/super-rss-reader/public/css/style.min.css?ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='https://www.palestinechronicle.com/wp-content/themes/mh-magazine/style.css?ver=3.8.12' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-child-css'  href='https://www.palestinechronicle.com/wp-content/themes/mh-magazine-child/style.css?ver=1.6.20' type='text/css' media='all' />
<link rel='stylesheet' id='jquery_modal_css-css'  href='https://cdnjs.cloudflare.com/ajax/libs/jquery-modal/0.9.1/jquery.modal.min.css?ver=0.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='font_awesome_css-css'  href='https://www.palestinechronicle.com/wp-content/themes/mh-magazine-child/fontawesome.min.css?ver=5.12.1' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://www.palestinechronicle.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:300,400,400italic,600,700' type='text/css' media='all' />
<script type='text/javascript' src='https://www.palestinechronicle.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.palestinechronicle.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.palestinechronicle.com/wp-content/plugins/super-rss-reader/public/js/jquery.easy-ticker.min.js?ver=4.3' id='jquery-easy-ticker-js'></script>
<script type='text/javascript' src='https://www.palestinechronicle.com/wp-content/plugins/super-rss-reader/public/js/script.min.js?ver=4.3' id='super-rss-reader-js'></script>
<script type='text/javascript' src='https://www.palestinechronicle.com/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.12' id='mh-scripts-js'></script>
<script type='text/javascript' src='//www.palestinechronicle.com/wp-content/plugins/tabber-widget/js/jquery.idTabs.min.js?ver=5.8.4' id='tabber_widget-idtabs-js'></script>
<link rel="https://api.w.org/" href="https://www.palestinechronicle.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.palestinechronicle.com/wp-json/wp/v2/posts/77268" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.palestinechronicle.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.palestinechronicle.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.4" />
<link rel='shortlink' href='https://www.palestinechronicle.com/?p=77268' />
<link rel="alternate" type="application/json+oembed" href="https://www.palestinechronicle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.palestinechronicle.com%2Fwe-will-not-forget-palestinians-commemorate-land-day-in-gaza-photos%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.palestinechronicle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.palestinechronicle.com%2Fwe-will-not-forget-palestinians-commemorate-land-day-in-gaza-photos%2F&#038;format=xml" />
<!--[if lt IE 9]>
<script src="https://www.palestinechronicle.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<link rel="icon" href="https://www.palestinechronicle.com/wp-content/uploads/2021/01/cropped-palestine_chronicle_footer_new_logo-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.palestinechronicle.com/wp-content/uploads/2021/01/cropped-palestine_chronicle_footer_new_logo-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.palestinechronicle.com/wp-content/uploads/2021/01/cropped-palestine_chronicle_footer_new_logo-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.palestinechronicle.com/wp-content/uploads/2021/01/cropped-palestine_chronicle_footer_new_logo-270x270.png" />
<script language="javascript" type="text/javascript">
	var isSocial = false;

	// JavaScript Document
  /*var cname = '88D99054olelkv672Nnthjhgad931bbak4cd';
  if( ( document.cookie == "" || document.cookie == null || ( document.cookie.indexOf(cname + '=') == -1 ) ) ) {
		isSocial = true;
    var cvalue = Math.floor((Math.random() * 10000000) + 1);
    var d = new Date();
    var exdays = 30;
    d.setTime(d.getTime() + (exdays*24*60*60*1000));
    var expires = "expires="+ d.toUTCString();
    document.cookie = cname + "=" + cvalue + ";" + expires + ";path=/";
		
		jQuery(window).load(function(){
			jQuery('#social_media_box').modal({
				fadeDuration: 750,
				fadeDelay: 1.0
			});
		});
  }*/

  // JavaScript Document
  var cname = '10D901734relkv677iGHerhiov731bBAK4D!';
  if( !isSocial && /*screen.width > 480 && */( document.cookie == "" || document.cookie == null || ( document.cookie.indexOf(cname + '=') == -1 )) ) {
    var cvalue = Math.floor((Math.random() * 10000000) + 1);
    var d = new Date();
    var exdays = 7;
    d.setTime(d.getTime() + (exdays*24*60*60*1000));
    var expires = "expires="+ d.toUTCString();
    document.cookie = cname + "=" + cvalue + ";" + expires + ";path=/";
		//document.cookie = cname + "=" + cvalue + ";path=/";
		
		jQuery(window).load(function(){
			jQuery('#donate_box').modal({
				fadeDuration: 750,
				fadeDelay: 1.0
			});
		});
  }
	
	
	//Close Thermometer Box
	jQuery(window).load(function(){
		var cthermo = 'thermometer_cookie_2022_04_1';
		jQuery( "#close_thermometer_box" ).click(function() { 
			//Hide the box
			jQuery( "#header-container, #close_thermometer_box" ).hide( "slow", function() { });

			//Define the cookies
			var cthermo_val = Math.floor((Math.random() * 10000000) + 1);
			var d = new Date();
			var exdays = 3;
			d.setTime(d.getTime() + (exdays*24*60*60*1000));
			var expires = "expires="+ d.toUTCString();
			document.cookie = cthermo + "=" + cthermo_val + ";" + expires + ";path=/";
			//document.cookie = cthermo + "=" + cthermo_val + ";path=/";
		});

		//In case cookie is expired, show the box
		if( document.cookie.indexOf(cthermo + '=') == -1 ) {
			jQuery( "div#thermometer_box, a#close_thermometer_box" ).removeClass( "hide" );
		}
	});
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
</head>
<body id="mh-mobile" class="post-template post-template-template-full post-template-template-full-php single single-post postid-77268 single-format-standard wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout1 mh-widget-layout1" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<a href="#" id="close_thermometer_box" class="close hide">&nbsp;</a>
<div id="thermometer_box" class="cta-super-header-applied header-container-slim cta-super-header-showing hide">
  <div id="header-container">
    <div id="header-top">
      <div class="l-header">
        <div class="col header-left">
          <a href="https://www.palestinechronicle.com/i-support-the-palestine-chronicle-help-us-so-that-our-voice-may-continue-to-be-heard/" title="Your Urgent Support Will Keep Us Fighting for Palestinian Freedom" target="_blank" style="font-size: 23px;"><b>Your Urgent Support Will Keep Us Fighting for Palestinian Freedom</b></a>
        </div>

        <div class="col header-middle" style="display:none;">
          <h4 style="color:#e64946"><center>We Raised $100  -- We Still Need $11,900</center></h4>
        </div>
        <div class="col header-right">
          <a class="button button--primary" href="https://www.paypal.com/cgi-bin/webscr?cmd=_donations&business=editor@palestinechronicle.com" target="_blank">DONATE NOW</a> 
          &nbsp; &nbsp;
          <a class="button button--primary" href="http://www.palestinechronicle.com/support-the-chronicle/" target="_blank">LEARN MORE</a> 
        </div>
      </div>
      
      <div class="l-header fund_sub_title" style="margin-top: 5px;">
      	<q>We are proud to announce that the Palestine Chronicle is fully supported and financed by its readers. This is community journalism at its best. Our impact is vast and our ambitions are great. But to continue, we need your immediate and urgent support. Please continue to stand by us. </q>
      </div>
      
      <!-- Start The thermometer -->
      <div class="l-header" >
      	<div id=countdown-wrap>
         	<div class="goal-stat">
            <span class="goal-number">%1 Funded</span>
          </div>
          <div id="goal">$12,000</div>
          <div id="glass">
            <div id="progress"></div>
          </div>
          <div class="goal-stat" style="display:none !important">
            <span class="goal-number">180 kontaktóra</span>
            <span class="goal-label">Raised</span>
          </div>
          <div class="goal-stat" style="display:none !important">
            <span class="goal-number"><div id="countdown"></div></span>
            <span class="goal-label">Days to Go</span>
          </div>
          <div class="goal-stat" style="display:none !important">
            <span class="goal-number">38</span>
            <span class="goal-label">Sponsors</span>
          </div>
        </div>
      </div>
      <style type="text/css">
			.hide {
				display:none;
			}
      #countdown-wrap {
				width: 100%;
				min-height: 70px;
				padding: 0px; /*10px*/
				font-family: arial;
				max-width: 850px;
				margin: 5px auto 0px;
			}
			
			#goal {
				font-size: 20px;/*26px*/
				text-align: right;
				color: black;
				@media only screen and (max-width : 640px) {
					text-align: center;  
				}
				
			}
			
			#glass {
				width: 100%;
				height: 20px;
				background: black;
				border-radius: 10px;
				float: left;
				overflow: hidden;
			}
			
			#progress {
				float: left;
				width: 1%;
				height: 20px;
				background: green;
				z-index: 333;
				/*border-radius: 5px;*/
			}
			
			.goal-stat {
				width: 50%;
				height: 15px;
				padding: 5px 10px;
				float: left;
				margin: 0;
				color: black;
				
				@media only screen and (max-width : 640px) {
					width: 50%;
					text-align: center;
				}
			}
			
			.goal-number, .goal-label {
				display: block;
				font-size:16px; /*18px*/
			}
			
			.goal-number {
				font-weight: bold;
			}
			
			.fund_sub_title {
				font-size:18px;
				@media only screen and (max-width : 640px) {
					font-size:14px;
				}
				
			}

			/* Add X button to the donation box */
			#close_thermometer_box {
				position: absolute;
				right: 10px;
				top: 145px;
				width: 32px;
				height: 32px;
				opacity: 0.5;
				z-index: 100;
			}
			#close_thermometer_box:hover {
				opacity: 1;
			}
			#close_thermometer_box:before, #close_thermometer_box:after {
				position: absolute;
				left: 15px;
				content: ' ';
				height: 33px;
				width: 2px;
				background-color: #A81817;
			}
			#close_thermometer_box:before {
				transform: rotate(45deg);
			}
			#close_thermometer_box:after {
				transform: rotate(-45deg);
			}
      </style>
      <!-- End The thermometer -->
    </div>
  </div>
</div>
<div class="mh-header-nav-mobile clearfix"></div>
	<div class="mh-preheader">
    	<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
											<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
							<div class="menu-top-menu-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-33333" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-33333"><a href="https://www.palestinechronicle.com">English</a></li>
<li id="menu-item-33334" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33334"><a target="_blank" rel="noopener" href="https://chroniquepalestine.com">Français</a></li>
</ul></div>						</nav>
									</div>
										<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
											<nav class="mh-social-icons mh-social-nav mh-social-nav-top clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
							<div class="menu-social-media-icons-container"><ul id="menu-social-media-icons" class="menu"><li id="menu-item-33331" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33331"><a target="_blank" rel="noopener" href="https://www.facebook.com/palestinechronicle/?ref=ts"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-33332" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33332"><a target="_blank" rel="noopener" href="https://twitter.com/PalestineChron"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-57410" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57410"><a target="_blank" rel="noopener" href="https://www.instagram.com/palestinechron/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Instagram</span></a></li>
<li id="menu-item-60097" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60097"><a target="_blank" rel="noopener" href="https://www.youtube.com/channel/UC2J3olQxMEQLEmpzisRVzpg/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Youtube</span></a></li>
</ul></div>						</nav>
									</div>
					</div>
	</div>
<header class="mh-header" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="http://schema.org/Brand">
<a href="https://www.palestinechronicle.com/" class="custom-logo-link" rel="home"><img width="800" height="304" src="https://www.palestinechronicle.com/wp-content/uploads/2021/01/palestine_chronicle_new_logo.png" class="custom-logo" alt="Palestine Chronicle" srcset="https://www.palestinechronicle.com/wp-content/uploads/2021/01/palestine_chronicle_new_logo.png 800w, https://www.palestinechronicle.com/wp-content/uploads/2021/01/palestine_chronicle_new_logo-495x188.png 495w, https://www.palestinechronicle.com/wp-content/uploads/2021/01/palestine_chronicle_new_logo-768x292.png 768w" sizes="(max-width: 800px) 100vw, 800px" /></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="text-28" class="mh-widget mh-header-2 widget_text">			<div class="textwidget"><a title="These Chains Will Be Broken: Palestinian Stories of Struggle and Defiance in Israeli Prisons" href="https://www.amazon.com/These-Chains-Will-Broken-Palestinian/dp/1949762092" target="_blank" rel="noopener"><img loading="lazy" class="alignnone wp-image-57268 size-full" src="https://www.palestinechronicle.com/wp-content/uploads/2021/03/Winter-Clearance-thump.png" alt="" width="100%" height="auto" /></a></div>
		</div></aside>
</div>
</div>
    
    <div id="info" style="text-align:center">
     <div class="date_updated">
			Wednesday, March 30, 2022 <span class="last_update">Last Update:   <mark style="background-color:rgba(80,0,0,0.2);"><span style="color:#A81817">9:13 PM GMT</span></mark></span>
		 </div>
		</div>
    
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
			<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-33428" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-33428"><a href="https://www.palestinechronicle.com/">Home Page</a></li>
<li id="menu-item-33322" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-33322"><a href="https://www.palestinechronicle.com/category/articles/">Articles</a></li>
<li id="menu-item-33323" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33323"><a href="https://www.palestinechronicle.com/category/news/">News</a></li>
<li id="menu-item-33324" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33324"><a href="https://www.palestinechronicle.com/blog/">Blog</a></li>
<li id="menu-item-33326" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33326"><a href="https://www.palestinechronicle.com/category/videos/">Videos</a></li>
<li id="menu-item-33327" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33327"><a href="https://www.palestinechronicle.com/category/articles/reviews/">Reviews</a></li>
<li id="menu-item-33328" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33328"><a href="https://www.palestinechronicle.com/about/">About</a></li>
<li id="menu-item-33329" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33329"><a href="https://www.palestinechronicle.com/support-the-chronicle/">Support Us</a></li>
<li id="menu-item-33330" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33330"><a href="https://www.palestinechronicle.com/contact-us/">Contact Us</a></li>
</ul></div>		</nav>
	</div>
			<div class="mh-extra-nav-wrap">
			<div class="mh-extra-nav-bg">
				<nav class="mh-navigation mh-extra-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
									</nav>
			</div>
		</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<div class="mh-header-ticker mh-header-ticker-bottom">
							<div class="mh-ticker-bottom">
			<div class="mh-ticker-title mh-ticker-title-bottom">
			News Ticker<i class="fa fa-chevron-right"></i>		</div>
		<div class="mh-ticker-content mh-ticker-content-bottom">
		<ul id="mh-ticker-loop-bottom">				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://www.palestinechronicle.com/we-will-not-forget-palestinians-commemorate-land-day-in-gaza-photos/" title="‘We Will Not Forget’: Palestinians Commemorate Land Day in Gaza (PHOTOS)">
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							‘We Will Not Forget’: Palestinians Commemorate Land Day in Gaza (PHOTOS)						</span>
						           	<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
							[ March 30, 2022 ]            </span>
					</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://www.palestinechronicle.com/gazas-forthcoming-crisis-might-be-worse-than-anything-we-have-ever-seen/" title="Gaza’s Forthcoming Crisis Might Be Worse than Anything We Have Ever Seen">
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Gaza’s Forthcoming Crisis Might Be Worse than Anything We Have Ever Seen						</span>
						           	<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
							[ March 30, 2022 ]            </span>
					</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://www.palestinechronicle.com/lowkey-a-hip-hop-voice-for-the-palestinian-struggle/" title="Lowkey: a Hip-Hop Voice for the Palestinian Struggle">
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Lowkey: a Hip-Hop Voice for the Palestinian Struggle						</span>
						           	<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
							[ March 30, 2022 ]            </span>
					</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://www.palestinechronicle.com/church-leaders-denounce-illegal-takeover-of-property-by-extremist-settlers-in-jerusalem/" title="Church Leaders Denounce &#8216;Illegal&#8217; Takeover of Property by &#8216;Extremist&#8217; Settlers in Jerusalem">
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Church Leaders Denounce &#8216;Illegal&#8217; Takeover of Property by &#8216;Extremist&#8217; Settlers in Jerusalem						</span>
						           	<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
							[ March 30, 2022 ]            </span>
					</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://www.palestinechronicle.com/dozens-of-artists-celebrities-come-out-in-support-of-pro-palestine-rapper-lowkey-videos/" title="Dozens of Artists, Celebrities Come out in Support of Pro-Palestine Rapper Lowkey (VIDEOS)">
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Dozens of Artists, Celebrities Come out in Support of Pro-Palestine Rapper Lowkey (VIDEOS)						</span>
						           	<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
							[ March 30, 2022 ]            </span>
					</a>
				</li>		</ul>
	</div>
</div>						</div>
									</div>
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<aside class="mh-header-search mh-header-search-bottom">
							<form role="search" method="get" class="search-form" action="https://www.palestinechronicle.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</aside>
									</div>
					</div>
	</div>
<div class="mh-wrapper clearfix" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.palestinechronicle.com" itemprop="url"><span itemprop="title">Home</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.palestinechronicle.com/category/articles/" itemprop="url"><span itemprop="title">Articles</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>‘We Will Not Forget’: Palestinians Commemorate Land Day in Gaza (PHOTOS)</nav>
<article id="post-77268" class="post-77268 post type-post status-publish format-standard has-post-thumbnail hentry category-articles category-features category-images category-slider tag-gaza tag-israeli-apartheid tag-israeli-occupation tag-land-day tag-palestine-chronicle-tv tag-resistance tag-sumoud tag-west-bank writers-palestine-chronicle-staff">
	<header class="entry-header clearfix"><h1 class="entry-title">‘We Will Not Forget’: Palestinians Commemorate Land Day in Gaza (PHOTOS)</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.palestinechronicle.com/2022/03/">March 30, 2022</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.palestinechronicle.com/category/articles/" rel="category tag">Articles</a>, <a href="https://www.palestinechronicle.com/category/articles/features/" rel="category tag">Features</a>, <a href="https://www.palestinechronicle.com/category/images/" rel="category tag">Images</a>, <a href="https://www.palestinechronicle.com/category/slider/" rel="category tag">Slider</a></span>
</div>
	</header>
		<div class="entry-content clearfix">
<figure class="entry-thumbnail">
<img src="https://www.palestinechronicle.com/wp-content/uploads/2022/03/Land-Day2-678x438.png" alt="" title="Land-Day2" />
<figcaption class="wp-caption-text">Palestinians commemorate Land Day in Gaza. (Photo: Mahmoud Ajjour, The Palestine Chronicle)</figcaption>
</figure>
<div class="mh-social-top">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.palestinechronicle.com%2Fwe-will-not-forget-palestinians-commemorate-land-day-in-gaza-photos%2F&t=%E2%80%98We+Will+Not+Forget%E2%80%99%3A+Palestinians+Commemorate+Land+Day+in+Gaza+%28PHOTOS%29', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=%E2%80%98We+Will+Not+Forget%E2%80%99%3A+Palestinians+Commemorate+Land+Day+in+Gaza+%28PHOTOS%29&url=https%3A%2F%2Fwww.palestinechronicle.com%2Fwe-will-not-forget-palestinians-commemorate-land-day-in-gaza-photos%2F&via=PalestineChron', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
  	<a class="mh-email" href="mailto:?subject=%E2%80%98We%20Will%20Not%20Forget%E2%80%99%3A%20Palestinians%20Commemorate%20Land%20Day%20in%20Gaza%20%28PHOTOS%29&amp;body=https%3A%2F%2Fwww.palestinechronicle.com%2Fwe-will-not-forget-palestinians-commemorate-land-day-in-gaza-photos%2F" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
</div></div>
<p><strong>By <a href="/writers/palestine-chronicle-staff" title="Display all articles for Palestine Chronicle Staff">Palestine Chronicle Staff</a></strong></p><p><span style="font-weight: 400;">Palestinians in Gaza participated in a rally marking the 46th anniversary of Palestinian Land Day near the fishermen&#8217;s port in Gaza City.</span></p>
<p><span style="font-weight: 400;">Land Day, celebrated on March 30 each year, is a crucial date in the Palestinian collective memory. It dates back to 1976 when six Palestinians were killed by the Israeli army during demonstrations staged against Israel’s confiscation of Palestinian land.</span></p>
<p><a href="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1376-scaled.jpg"><img loading="lazy" class="alignnone size-full wp-image-77270" src="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1376-scaled.jpg" alt="" width="2560" height="1707" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1376-scaled.jpg 2560w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1376-420x280.jpg 420w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1376-1024x683.jpg 1024w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1376-768x512.jpg 768w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1376-1536x1024.jpg 1536w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1376-2048x1365.jpg 2048w" sizes="(max-width: 2560px) 100vw, 2560px" /></a> <a href="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1429-scaled.jpg"><img loading="lazy" class="alignnone size-full wp-image-77271" src="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1429-scaled.jpg" alt="" width="2560" height="1707" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1429-scaled.jpg 2560w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1429-420x280.jpg 420w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1429-1024x683.jpg 1024w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1429-768x512.jpg 768w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1429-1536x1024.jpg 1536w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1429-2048x1365.jpg 2048w" sizes="(max-width: 2560px) 100vw, 2560px" /></a> <a href="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1498-scaled.jpg"><img loading="lazy" class="alignnone size-full wp-image-77272" src="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1498-scaled.jpg" alt="" width="2560" height="1707" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1498-scaled.jpg 2560w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1498-420x280.jpg 420w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1498-1024x683.jpg 1024w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1498-768x512.jpg 768w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1498-1536x1024.jpg 1536w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1498-2048x1365.jpg 2048w" sizes="(max-width: 2560px) 100vw, 2560px" /></a> <a href="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1527-scaled.jpg"><img loading="lazy" class="alignnone size-full wp-image-77273" src="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1527-scaled.jpg" alt="" width="2560" height="1707" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1527-scaled.jpg 2560w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1527-420x280.jpg 420w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1527-1024x683.jpg 1024w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1527-768x512.jpg 768w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1527-1536x1024.jpg 1536w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1527-2048x1365.jpg 2048w" sizes="(max-width: 2560px) 100vw, 2560px" /></a> <a href="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1598-scaled.jpg"><img loading="lazy" class="alignnone size-full wp-image-77274" src="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1598-scaled.jpg" alt="" width="2560" height="1763" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1598-scaled.jpg 2560w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1598-407x280.jpg 407w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1598-1024x705.jpg 1024w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1598-768x529.jpg 768w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1598-1536x1058.jpg 1536w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR1598-2048x1411.jpg 2048w" sizes="(max-width: 2560px) 100vw, 2560px" /></a></p>
<p><span style="font-weight: 400;">Every year, a variety of rallies and activities are scheduled across the occupied Palestinian territories. </span></p>
<p><span style="font-weight: 400;">In Gaza, celebrations started a few days ago, with a rally near the fence separating besieged Gaza from Israel. </span></p>
<p><span style="font-weight: 400;">On Tuesday, a massive rally was held at the fishermen&#8217;s port, in the presence of Yahya Sinwar, the leader of Hamas in the Gaza Strip. </span></p>
<p><a href="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3205-scaled.jpg"><img loading="lazy" class="alignnone size-full wp-image-77275" src="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3205-scaled.jpg" alt="" width="2560" height="1707" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3205-scaled.jpg 2560w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3205-420x280.jpg 420w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3205-1024x683.jpg 1024w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3205-768x512.jpg 768w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3205-1536x1024.jpg 1536w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3205-2048x1365.jpg 2048w" sizes="(max-width: 2560px) 100vw, 2560px" /></a> <a href="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3172-scaled.jpg"><img loading="lazy" class="alignnone size-full wp-image-77276" src="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3172-scaled.jpg" alt="" width="2560" height="1707" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3172-scaled.jpg 2560w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3172-420x280.jpg 420w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3172-1024x683.jpg 1024w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3172-768x512.jpg 768w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3172-1536x1024.jpg 1536w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3172-2048x1365.jpg 2048w" sizes="(max-width: 2560px) 100vw, 2560px" /></a> <a href="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3316-scaled.jpg"><img loading="lazy" class="alignnone size-full wp-image-77277" src="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3316-scaled.jpg" alt="" width="2560" height="1707" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3316-scaled.jpg 2560w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3316-420x280.jpg 420w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3316-1024x683.jpg 1024w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3316-768x512.jpg 768w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3316-1536x1024.jpg 1536w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3316-2048x1365.jpg 2048w" sizes="(max-width: 2560px) 100vw, 2560px" /></a> <a href="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3334-scaled.jpg"><img loading="lazy" class="alignnone size-full wp-image-77278" src="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3334-scaled.jpg" alt="" width="2560" height="1707" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3334-scaled.jpg 2560w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3334-420x280.jpg 420w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3334-1024x683.jpg 1024w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3334-768x512.jpg 768w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3334-1536x1024.jpg 1536w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3334-2048x1365.jpg 2048w" sizes="(max-width: 2560px) 100vw, 2560px" /></a> <a href="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3365-scaled.jpg"><img loading="lazy" class="alignnone size-full wp-image-77279" src="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3365-scaled.jpg" alt="" width="2560" height="1707" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3365-scaled.jpg 2560w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3365-420x280.jpg 420w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3365-1024x683.jpg 1024w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3365-768x512.jpg 768w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3365-1536x1024.jpg 1536w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3365-2048x1365.jpg 2048w" sizes="(max-width: 2560px) 100vw, 2560px" /></a> <a href="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3393-scaled.jpg"><img loading="lazy" class="alignnone size-full wp-image-77280" src="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3393-scaled.jpg" alt="" width="2560" height="1707" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3393-scaled.jpg 2560w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3393-420x280.jpg 420w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3393-1024x683.jpg 1024w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3393-768x512.jpg 768w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3393-1536x1024.jpg 1536w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3393-2048x1365.jpg 2048w" sizes="(max-width: 2560px) 100vw, 2560px" /></a></p>
<p><span style="font-weight: 400;">Palestinians also gathered in the streets waving Palestinian flags and photos of political prisoners. </span></p>
<p>The Palestine Chronicle talked to one of the women about the importance of this national celebration.</p>
<p>“On our Land Day, it is the duty of the Palestinian people to show our strength and resist the occupation,” the woman said.</p>
<p><a href="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3460-scaled.jpg"><img loading="lazy" class="alignnone size-full wp-image-77281" src="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3460-scaled.jpg" alt="" width="2560" height="1707" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3460-scaled.jpg 2560w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3460-420x280.jpg 420w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3460-1024x683.jpg 1024w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3460-768x512.jpg 768w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3460-1536x1024.jpg 1536w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3460-2048x1365.jpg 2048w" sizes="(max-width: 2560px) 100vw, 2560px" /></a> <a href="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3470-scaled.jpg"><img loading="lazy" class="alignnone size-full wp-image-77282" src="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3470-scaled.jpg" alt="" width="2560" height="1707" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3470-scaled.jpg 2560w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3470-420x280.jpg 420w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3470-1024x683.jpg 1024w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3470-768x512.jpg 768w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3470-1536x1024.jpg 1536w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3470-2048x1365.jpg 2048w" sizes="(max-width: 2560px) 100vw, 2560px" /></a> <a href="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3480-scaled.jpg"><img loading="lazy" class="alignnone size-full wp-image-77283" src="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3480-scaled.jpg" alt="" width="2560" height="1707" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3480-scaled.jpg 2560w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3480-420x280.jpg 420w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3480-1024x683.jpg 1024w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3480-768x512.jpg 768w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3480-1536x1024.jpg 1536w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3480-2048x1365.jpg 2048w" sizes="(max-width: 2560px) 100vw, 2560px" /></a> <a href="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3493-scaled.jpg"><img loading="lazy" class="alignnone size-full wp-image-77284" src="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3493-scaled.jpg" alt="" width="2560" height="1707" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3493-scaled.jpg 2560w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3493-420x280.jpg 420w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3493-1024x683.jpg 1024w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3493-768x512.jpg 768w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3493-1536x1024.jpg 1536w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3493-2048x1365.jpg 2048w" sizes="(max-width: 2560px) 100vw, 2560px" /></a> <a href="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3534-scaled.jpg"><img loading="lazy" class="alignnone size-full wp-image-77285" src="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3534-scaled.jpg" alt="" width="2560" height="1707" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3534-scaled.jpg 2560w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3534-420x280.jpg 420w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3534-1024x683.jpg 1024w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3534-768x512.jpg 768w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3534-1536x1024.jpg 1536w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3534-2048x1365.jpg 2048w" sizes="(max-width: 2560px) 100vw, 2560px" /></a> <a href="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3557-scaled.jpg"><img loading="lazy" class="alignnone size-full wp-image-77286" src="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3557-scaled.jpg" alt="" width="2560" height="1707" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3557-scaled.jpg 2560w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3557-420x280.jpg 420w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3557-1024x683.jpg 1024w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3557-768x512.jpg 768w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3557-1536x1024.jpg 1536w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3557-2048x1365.jpg 2048w" sizes="(max-width: 2560px) 100vw, 2560px" /></a> <a href="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3593-scaled.jpg"><img loading="lazy" class="alignnone size-full wp-image-77287" src="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3593-scaled.jpg" alt="" width="2560" height="1707" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3593-scaled.jpg 2560w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3593-420x280.jpg 420w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3593-1024x683.jpg 1024w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3593-768x512.jpg 768w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3593-1536x1024.jpg 1536w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3593-2048x1365.jpg 2048w" sizes="(max-width: 2560px) 100vw, 2560px" /></a> <a href="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3631-scaled.jpg"><img loading="lazy" class="alignnone size-full wp-image-77288" src="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3631-scaled.jpg" alt="" width="2560" height="1707" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3631-scaled.jpg 2560w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3631-420x280.jpg 420w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3631-1024x683.jpg 1024w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3631-768x512.jpg 768w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3631-1536x1024.jpg 1536w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/AJUR3631-2048x1365.jpg 2048w" sizes="(max-width: 2560px) 100vw, 2560px" /></a></p>
<p>“Israelis believe that old Palestinians will forget their right of return and that young people do not know the true value of freedom. But here we are, old and young, all together, saying out loud that we shall return to our home. And that, despite the hardship and suffering we have to endure every day, we will fight for freedom and liberate our occupied homeland.”</p>
<p><span style="font-weight: 400;">Land Day represents an opportunity to commemorate the tragic events of 1976 but also to reiterate that Palestinians are still united in their struggle for freedom and justice.</span></p>
<p><i><span style="font-weight: 400;">(All Photos: Mahmoud Ajjour, The Palestine Chronicle)</span></i></p>
<div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.palestinechronicle.com%2Fwe-will-not-forget-palestinians-commemorate-land-day-in-gaza-photos%2F&t=%E2%80%98We+Will+Not+Forget%E2%80%99%3A+Palestinians+Commemorate+Land+Day+in+Gaza+%28PHOTOS%29', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=%E2%80%98We+Will+Not+Forget%E2%80%99%3A+Palestinians+Commemorate+Land+Day+in+Gaza+%28PHOTOS%29&url=https%3A%2F%2Fwww.palestinechronicle.com%2Fwe-will-not-forget-palestinians-commemorate-land-day-in-gaza-photos%2F&via=PalestineChron', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
  	<a class="mh-email" href="mailto:?subject=%E2%80%98We%20Will%20Not%20Forget%E2%80%99%3A%20Palestinians%20Commemorate%20Land%20Day%20in%20Gaza%20%28PHOTOS%29&amp;body=https%3A%2F%2Fwww.palestinechronicle.com%2Fwe-will-not-forget-palestinians-commemorate-land-day-in-gaza-photos%2F" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
</div></div>
	</div>
	
  <div id="inner_pages_fundraiser">
    <img src="https://www.palestinechronicle.com/wp-content/themes/mh-magazine-child/support-the-palestine-chronicle.jpg" />
    <div class="inner_pages_fundraiser_buttons">
      <a href="https://www.paypal.com/donate/?cmd=_donations&business=editor@palestinechronicle.com" target="_blank" class="donate_now">Donate NOW</a> &nbsp; &nbsp;
      <a href="/support-the-chronicle/">Learn More</a> &nbsp; &nbsp;
      <a href="https://www.youtube.com/watch?v=9b-4ihMjgKg&feature=emb_logo">Watch Video</a>
    </div>
    <center style="font-size: 9px; color:#000;">(The Palestine Chronicle is a <a style="color: #e64946;" href="/about/">registered</a> 501(c)3 organization, thus, all donations are tax deductible.)</center>
  </div>
  
	<div class="entry-tags clearfix"><i class="fa fa-tag"></i><ul><li><a href="https://www.palestinechronicle.com/tag/gaza/" rel="tag">gaza</a></li><li><a href="https://www.palestinechronicle.com/tag/israeli-apartheid/" rel="tag">Israeli apartheid</a></li><li><a href="https://www.palestinechronicle.com/tag/israeli-occupation/" rel="tag">Israeli Occupation</a></li><li><a href="https://www.palestinechronicle.com/tag/land-day/" rel="tag">Land Day</a></li><li><a href="https://www.palestinechronicle.com/tag/palestine-chronicle-tv/" rel="tag">Palestine Chronicle TV</a></li><li><a href="https://www.palestinechronicle.com/tag/resistance/" rel="tag">resistance</a></li><li><a href="https://www.palestinechronicle.com/tag/sumoud/" rel="tag">sumoud</a></li><li><a href="https://www.palestinechronicle.com/tag/west-bank/" rel="tag">West Bank</a></li></ul></div></article><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://www.palestinechronicle.com/gazas-forthcoming-crisis-might-be-worse-than-anything-we-have-ever-seen/" rel="prev"><img width="80" height="60" src="https://www.palestinechronicle.com/wp-content/uploads/2022/03/Gaza-water-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" loading="lazy" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/03/Gaza-water-80x60.png 80w, https://www.palestinechronicle.com/wp-content/uploads/2022/03/Gaza-water-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" /><span>Previous</span><p>Gaza’s Forthcoming Crisis Might Be Worse than Anything We Have Ever Seen</p></a></div>
</nav>
<section class="mh-related-content">
<h3 class="mh-widget-title mh-related-content-title">
<span class="mh-widget-title-inner">Related Articles</span></h3>
<div class="mh-related-wrap mh-row clearfix">
<div class="mh-col-1-3 mh-posts-grid-col clearfix">
<article class="post-37200 format-standard mh-posts-grid-item clearfix">
	<figure class="mh-posts-grid-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://www.palestinechronicle.com/erdogan-calls-israel-premier-occupier-terrorist/" title="Erdogan Calls Netanyahu &#8216;Occupier&#8217; and &#8216;Terrorist&#8217; (VIDEO)"><img width="326" height="245" src="https://www.palestinechronicle.com/wp-content/uploads/2018/04/Untitled-design-4-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="" loading="lazy" srcset="https://www.palestinechronicle.com/wp-content/uploads/2018/04/Untitled-design-4-326x245.jpg 326w, https://www.palestinechronicle.com/wp-content/uploads/2018/04/Untitled-design-4-80x60.jpg 80w" sizes="(max-width: 326px) 100vw, 326px" />		</a>
					<div class="mh-image-caption mh-posts-grid-caption">
				Blog			</div>
			</figure>
	<h3 class="entry-title mh-posts-grid-title">
		<a href="https://www.palestinechronicle.com/erdogan-calls-israel-premier-occupier-terrorist/" title="Erdogan Calls Netanyahu &#8216;Occupier&#8217; and &#8216;Terrorist&#8217; (VIDEO)" rel="bookmark">
			Erdogan Calls Netanyahu &#8216;Occupier&#8217; and &#8216;Terrorist&#8217; (VIDEO)		</a>
	</h3>
	<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.palestinechronicle.com/2018/04/">April 2, 2018</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.palestinechronicle.com/category/live-blog/" rel="category tag">Blog</a>, <a href="https://www.palestinechronicle.com/category/news/" rel="category tag">News</a></span>
</div>
	<div class="mh-posts-grid-excerpt clearfix">
		<div class="mh-excerpt"><p>Turkey’s president on Sunday criticized Israeli Prime Minister Benjamin Netanyahu over his remarks targeting Turkey’s ongoing operation in Afrin, Syria. “He says our soldiers are oppressing people in Afrin. Netanyahu, you are very weak, very <a class="mh-excerpt-more" href="https://www.palestinechronicle.com/erdogan-calls-israel-premier-occupier-terrorist/" title="Erdogan Calls Netanyahu &#8216;Occupier&#8217; and &#8216;Terrorist&#8217; (VIDEO)">[&#8230;]</a></p>
</div>	</div>
</article></div>
<div class="mh-col-1-3 mh-posts-grid-col clearfix">
<article class="post-65720 format-standard mh-posts-grid-item clearfix">
	<figure class="mh-posts-grid-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://www.palestinechronicle.com/the-left-and-israel/" title="German Hypocrisy: The Left and Israel"><img width="326" height="245" src="https://www.palestinechronicle.com/wp-content/uploads/2020/10/German-parliament-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="" loading="lazy" srcset="https://www.palestinechronicle.com/wp-content/uploads/2020/10/German-parliament-326x245.jpg 326w, https://www.palestinechronicle.com/wp-content/uploads/2020/10/German-parliament-80x60.jpg 80w" sizes="(max-width: 326px) 100vw, 326px" />		</a>
					<div class="mh-image-caption mh-posts-grid-caption">
				Articles			</div>
			</figure>
	<h3 class="entry-title mh-posts-grid-title">
		<a href="https://www.palestinechronicle.com/the-left-and-israel/" title="German Hypocrisy: The Left and Israel" rel="bookmark">
			German Hypocrisy: The Left and Israel		</a>
	</h3>
	<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.palestinechronicle.com/2020/10/">October 7, 2020</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.palestinechronicle.com/category/articles/" rel="category tag">Articles</a>, <a href="https://www.palestinechronicle.com/category/articles/commentary/" rel="category tag">Commentary</a></span>
</div>
	<div class="mh-posts-grid-excerpt clearfix">
		<div class="mh-excerpt"><p>Oxford Dictionary defines “hypocrisy” as a “behavior that does not meet the moral standards or match the opinions that somebody claims to have.” Transposed to the concrete issue of Palestine within political discourse in Germany, <a class="mh-excerpt-more" href="https://www.palestinechronicle.com/the-left-and-israel/" title="German Hypocrisy: The Left and Israel">[&#8230;]</a></p>
</div>	</div>
</article></div>
<div class="mh-col-1-3 mh-posts-grid-col clearfix">
<article class="post-59234 format-standard mh-posts-grid-item clearfix">
	<figure class="mh-posts-grid-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://www.palestinechronicle.com/israeli-forces-kill-young-palestinian-man-near-hebron/" title="Israeli Forces Kill Young Palestinian Man near Hebron"><img width="326" height="245" src="https://www.palestinechronicle.com/wp-content/uploads/2020/05/Bahaeddin-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="" loading="lazy" srcset="https://www.palestinechronicle.com/wp-content/uploads/2020/05/Bahaeddin-326x245.jpg 326w, https://www.palestinechronicle.com/wp-content/uploads/2020/05/Bahaeddin-80x60.jpg 80w" sizes="(max-width: 326px) 100vw, 326px" />		</a>
					<div class="mh-image-caption mh-posts-grid-caption">
				Blog			</div>
			</figure>
	<h3 class="entry-title mh-posts-grid-title">
		<a href="https://www.palestinechronicle.com/israeli-forces-kill-young-palestinian-man-near-hebron/" title="Israeli Forces Kill Young Palestinian Man near Hebron" rel="bookmark">
			Israeli Forces Kill Young Palestinian Man near Hebron		</a>
	</h3>
	<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.palestinechronicle.com/2020/05/">May 14, 2020</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.palestinechronicle.com/category/live-blog/" rel="category tag">Blog</a>, <a href="https://www.palestinechronicle.com/category/news/" rel="category tag">News</a></span>
</div>
	<div class="mh-posts-grid-excerpt clearfix">
		<div class="mh-excerpt"><p>A Palestinian young man was shot dead today by Israeli occupation forces outside the town of Beit Awwa, near the occupied West Bank town of Hebron (Al-Khalil). Israeli troops fired live bullets at the man, <a class="mh-excerpt-more" href="https://www.palestinechronicle.com/israeli-forces-kill-young-palestinian-man-near-hebron/" title="Israeli Forces Kill Young Palestinian Man near Hebron">[&#8230;]</a></p>
</div>	</div>
</article></div>
</div>
</section>
<div id="comments" class="mh-comments-wrap">
			<h4 class="mh-widget-title mh-comment-form-title">
				<span class="mh-widget-title-inner">
					Be the first to comment				</span>
			</h4>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/we-will-not-forget-palestinians-commemorate-land-day-in-gaza-photos/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.palestinechronicle.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><label for="comment"><small id="charNum" style="font-size:11px;">700 characters left</small></label></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="cptch_block"><span class="cptch_wrap cptch_math_actions">
				<label class="cptch_label" for="cptch_input_85"><span class="cptch_span">4</span>
					<span class="cptch_span">&nbsp;&times;&nbsp;</span>
					<span class="cptch_span">7</span>
					<span class="cptch_span">&nbsp;=&nbsp;</span>
					<span class="cptch_span"><input id="cptch_input_85" class="cptch_input cptch_wp_comments" type="text" autocomplete="off" name="cptch_number" value="" maxlength="2" size="2" aria-required="true" required="required" style="margin-bottom:0;display:inline;font-size: 12px;width: 40px;" /></span>
					<input type="hidden" name="cptch_result" value="m7WS" /><input type="hidden" name="cptch_time" value="1648677933" />
					<input type="hidden" name="cptch_form" value="wp_comments" />
				</label><span class="cptch_reload_button_wrap hide-if-no-js">
					<noscript>
						<style type="text/css">
							.hide-if-no-js {
								display: none !important;
							}
						</style>
					</noscript>
					<span class="cptch_reload_button dashicons dashicons-update"></span>
				</span></span></p><div class="anr_captcha_field"><div id="anr_captcha_field_1" class="anr_captcha_field_div"></div></div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='77268' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="19892d7f32" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js" name="ak_js" value="90"/><script>document.getElementById( "ak_js" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>	</div><!-- #respond -->
	</div>

<script type="text/javascript">
	jQuery( '#comment' ).keyup(function ( ) {
	var max = 700;
	var len = jQuery(this).val().length;
	if (len >= max) {
		jQuery('#charNum').text(' You have reached the limit!');
document.getElementById("comment").value= (document.getElementById("comment").value.substr(0, 700));
	} else {
		var char = max - len;
		jQuery('#charNum').text(char + ' characters left');
	}
});
</script></div>
<!--'DONATE NOW' Modal HTML embedded directly into document -->

<!--'DONATE NOW' Modal HTML embedded directly into document -->
<div id="donate_box" class="modal" style="width:100%;max-width:660px;">
  <div id="fund_raiser" class="cta-processed cta-super-header showing" style=" width:99%; margin:5px 0 0; background:none;">
    <div id="block-block-78" class="block block--block block--block-78">
      <div class="block__content">
        <div class="cta-content" style="display:block; padding:0px;">
          <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_donations&business=editor@palestinechronicle.com" target="_blank" style="color:#e64946;font-weight:bold;"><img src="https://www.palestinechronicle.com/wp-content/uploads/2020/10/noam_chomksy.jpg" title="Support the Palestine Chronicle" style="border:0px; max-width:100%;" /></a>
          <br />
          <div style="text-align:center; margin:10px 0">
          	<a href="https://www.paypal.com/cgi-bin/webscr?cmd=_donations&business=editor@palestinechronicle.com" target="_blank" style="color:#e64946;font-weight:bold;">Donate NOW</a> &nbsp; &nbsp;
            <a href="/support-the-chronicle/">Learn More</a> &nbsp; &nbsp;
            <a href="https://www.youtube.com/watch?v=9b-4ihMjgKg&feature=emb_logo">Watch Video</a>
          </div>
          <center style="font-size: 9px; color:#000;">(The Palestine Chronicle is a <a style="color: #e64946;" href="/about/">registered</a> 501(c)3 organization, thus, all donations are tax deductible.)</center>
        </div>
      </div>
    </div>
  </div>
</div>


<!--'Social Media Buttons' Modal HTML embedded directly into document -->



<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-3 mh-widget-col-1 mh-footer-3-cols  mh-footer-area mh-footer-1">
<div id="custom_html-6" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><center><img class="aligncenter wp-image-68016 size-full" src="https://www.palestinechronicle.com/wp-content/uploads/2021/01/palestine_chronicle_footer_new_logo.png" alt="NEWS &amp; VIEWS FROM PALESTINE AND THE MIDDLE EAST" width="220" height="220" /></center><span>
	&nbsp;
</span></div></div></div>
<div class="mh-col-1-3 mh-widget-col-1 mh-footer-3-cols  mh-footer-area mh-footer-2">
<div id="nav_menu-2" class="mh-footer-widget widget_nav_menu"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Our Network</span></h6><div class="menu-footer-menu-our-network-container"><ul id="menu-footer-menu-our-network" class="menu"><li id="menu-item-33309" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-33309"><a href="https://www.palestinechronicle.com/">Palestine Chronicle</a></li>
<li id="menu-item-33310" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33310"><a target="_blank" rel="noopener" href="https://www.chroniquepalestine.com/">Chronique de Palestine</a></li>
</ul></div></div><div id="mh_magazine_social-2" class="mh-footer-widget mh_magazine_social">				<nav class="mh-social-icons mh-social-widget clearfix">
					<div class="menu-social-media-icons-container"><ul id="menu-social-media-icons-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33331"><a target="_blank" rel="noopener" href="https://www.facebook.com/palestinechronicle/?ref=ts"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33332"><a target="_blank" rel="noopener" href="https://twitter.com/PalestineChron"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57410"><a target="_blank" rel="noopener" href="https://www.instagram.com/palestinechron/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Instagram</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60097"><a target="_blank" rel="noopener" href="https://www.youtube.com/channel/UC2J3olQxMEQLEmpzisRVzpg/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Youtube</span></a></li>
</ul></div>				</nav></div></div>
<div class="mh-col-1-3 mh-widget-col-1 mh-footer-3-cols  mh-footer-area mh-footer-3">
<div id="text-30" class="mh-footer-widget widget_text"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">About Us</span></h6>			<div class="textwidget">The Palestine Chronicle is a 501(c)3 non-profit organization whose mission is to educate the general public by providing a forum that strives to highlight issues of relevance to human rights, national struggles, freedom and democracy in the form of daily news, commentary, features, book reviews, photos, art, and more. <a class="footer_about" href="about/">Read More</a></div>
		</div></div>
</div>
</footer>
	<div class="mh-footer-nav-mobile"></div>
	<nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
		<div class="mh-container mh-container-inner clearfix">
			<div class="menu-footer-menu-more-container"><ul id="menu-footer-menu-more" class="menu"><li id="menu-item-33306" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33306"><a href="https://www.palestinechronicle.com/disclaimer/">Disclaimer</a></li>
<li id="menu-item-33307" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33307"><a href="https://www.palestinechronicle.com/category/articles/feed">RSS Feed</a></li>
<li id="menu-item-33308" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33308"><a href="https://www.palestinechronicle.com/contact-us/">Contact Us</a></li>
</ul></div>		</div>
	</nav>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">
			Copyright &copy; 1999-2022 PalestineChronicle.com. All rights reserved | Powered By <a href="http://mediaseniors.com/" title="Media Seniors" rel="nofollow">Media Seniors</a>		</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->

<!-- Constant Contact Widget by Katz Web Services, Inc. | http://www.seodenver.com/constant-contact-wordpress-widget/ -->

<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/jquery-modal/0.9.1/jquery.modal.min.js?ver=0.9.1' id='jquery_modal_js-js'></script>
<script type='text/javascript' src='https://www.palestinechronicle.com/wp-includes/js/comment-reply.min.js?ver=5.8.4' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.palestinechronicle.com/wp-content/plugins/page-links-to/dist/new-tab.js?ver=3.3.5' id='page-links-to-js'></script>
<script type='text/javascript' src='https://www.palestinechronicle.com/wp-includes/js/wp-embed.min.js?ver=5.8.4' id='wp-embed-js'></script>
<script type='text/javascript' id='cptch_front_end_script-js-extra'>
/* <![CDATA[ */
var cptch_vars = {"nonce":"76ac681e1a","ajaxurl":"https:\/\/www.palestinechronicle.com\/wp-admin\/admin-ajax.php","enlarge":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.palestinechronicle.com/wp-content/plugins/captcha/js/front_end_script.js?ver=5.8.4' id='cptch_front_end_script-js'></script>
			<script type="text/javascript">
				var anr_onloadCallback = function() {
					for ( var i = 0; i < document.forms.length; i++ ) {
						var form = document.forms[i];
						var captcha_div = form.querySelector( '.anr_captcha_field_div' );

						if ( null === captcha_div )
							continue;
						captcha_div.innerHTML = '';
						( function( form ) {
							var anr_captcha = grecaptcha.render( captcha_div,{
								'sitekey' : '6Lde46wUAAAAANFpHc20KUxDj9IroJc0pygYUIel',
								'size'  : 'normal',
								'theme' : 'light'
							});
							if ( typeof jQuery !== 'undefined' ) {
								jQuery( document.body ).on( 'checkout_error', function(){
									grecaptcha.reset(anr_captcha);
								});
							}
							if ( typeof wpcf7 !== 'undefined' ) {
								document.addEventListener( 'wpcf7submit', function() {
									grecaptcha.reset(anr_captcha);
								}, false );
							}
						})(form);
					}
				};
			</script>
						<script src="https://www.google.com/recaptcha/api.js?onload=anr_onloadCallback&#038;render=explicit"
				async defer>
			</script>
			</body>
</html>