<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-77928330-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-77928330-1');
</script>

<link rel="stylesheet" id="wp-forecast-css" href="https://www.palestinechronicle.com/wp-content/plugins/wp-forecast/wp-forecast-default.css" type="text/css" media="screen" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v18.5.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Palestinians Should Never Have to Wait to See Their Families - Palestine Chronicle</title>
	<meta name="description" content="I have a Palestinian friend who lives near me in Toronto. She wants to visit her family in Gaza but can’t. The authorities, both in Canada and Israel, are making it very difficult to get the right documents or permission to get there." />
	<link rel="canonical" href="https://www.palestinechronicle.com/palestinians-should-never-have-to-wait-to-see-their-families/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Palestinians Should Never Have to Wait to See Their Families" />
	<meta property="og:description" content="I have a Palestinian friend who lives near me in Toronto. She wants to visit her family in Gaza but can’t. The authorities, both in Canada and Israel, are making it very difficult to get the right documents or permission to get there." />
	<meta property="og:url" content="https://www.palestinechronicle.com/palestinians-should-never-have-to-wait-to-see-their-families/" />
	<meta property="og:site_name" content="Palestine Chronicle" />
	<meta property="article:publisher" content="https://www.facebook.com/pages/The-Palestine-Chronicle-PalestineChroniclecom/302592203117857?ref=ts&amp;amp%3bamp%3bfref=ts" />
	<meta property="article:published_time" content="2022-04-16T13:38:46+00:00" />
	<meta property="og:image" content="https://www.palestinechronicle.com/wp-content/uploads/2021/02/Rafah.jpg" />
	<meta property="og:image:width" content="678" />
	<meta property="og:image:height" content="455" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="admin" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="4 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.palestinechronicle.com/#website","url":"https://www.palestinechronicle.com/","name":"Palestine Chronicle","description":"NEWS &amp; VIEWS FROM PALESTINE AND THE MIDDLE EAST","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.palestinechronicle.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.palestinechronicle.com/palestinians-should-never-have-to-wait-to-see-their-families/#primaryimage","inLanguage":"en-US","url":"https://www.palestinechronicle.com/wp-content/uploads/2021/02/Rafah.jpg","contentUrl":"https://www.palestinechronicle.com/wp-content/uploads/2021/02/Rafah.jpg","width":678,"height":455,"caption":"Palestinians await permission to cross the Rafah Crossing. (Photo: ActiveStills.org)"},{"@type":"WebPage","@id":"https://www.palestinechronicle.com/palestinians-should-never-have-to-wait-to-see-their-families/#webpage","url":"https://www.palestinechronicle.com/palestinians-should-never-have-to-wait-to-see-their-families/","name":"Palestinians Should Never Have to Wait to See Their Families - Palestine Chronicle","isPartOf":{"@id":"https://www.palestinechronicle.com/#website"},"primaryImageOfPage":{"@id":"https://www.palestinechronicle.com/palestinians-should-never-have-to-wait-to-see-their-families/#primaryimage"},"datePublished":"2022-04-16T13:38:46+00:00","dateModified":"2022-04-16T13:38:46+00:00","author":{"@id":"https://www.palestinechronicle.com/#/schema/person/6876d6312c6aa18882ca63366a7b5926"},"description":"I have a Palestinian friend who lives near me in Toronto. She wants to visit her family in Gaza but can’t. The authorities, both in Canada and Israel, are making it very difficult to get the right documents or permission to get there.","breadcrumb":{"@id":"https://www.palestinechronicle.com/palestinians-should-never-have-to-wait-to-see-their-families/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.palestinechronicle.com/palestinians-should-never-have-to-wait-to-see-their-families/"]}]},{"@type":"BreadcrumbList","@id":"https://www.palestinechronicle.com/palestinians-should-never-have-to-wait-to-see-their-families/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.palestinechronicle.com/"},{"@type":"ListItem","position":2,"name":"Articles","item":"https://www.palestinechronicle.com/category/articles/"},{"@type":"ListItem","position":3,"name":"Palestinians Should Never Have to Wait to See Their Families"}]},{"@type":"Person","@id":"https://www.palestinechronicle.com/#/schema/person/6876d6312c6aa18882ca63366a7b5926","name":"admin","url":"https://www.palestinechronicle.com/author/admin/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//www.palestinechronicle.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Palestine Chronicle &raquo; Feed" href="https://www.palestinechronicle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Palestine Chronicle &raquo; Comments Feed" href="https://www.palestinechronicle.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Palestine Chronicle &raquo; Palestinians Should Never Have to Wait to See Their Families Comments Feed" href="https://www.palestinechronicle.com/palestinians-should-never-have-to-wait-to-see-their-families/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.palestinechronicle.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.4"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='cptch_stylesheet-css'  href='https://www.palestinechronicle.com/wp-content/plugins/captcha/css/front_end_style.css?ver=4.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.palestinechronicle.com/wp-includes/css/dashicons.min.css?ver=5.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='cptch_desktop_style-css'  href='https://www.palestinechronicle.com/wp-content/plugins/captcha/css/desktop_style.css?ver=4.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='super-rss-reader-css'  href='https://www.palestinechronicle.com/wp-content/plugins/super-rss-reader/public/css/style.min.css?ver=4.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='https://www.palestinechronicle.com/wp-content/themes/mh-magazine/style.css?ver=3.8.12' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-child-css'  href='https://www.palestinechronicle.com/wp-content/themes/mh-magazine-child/style.css?ver=1.6.20' type='text/css' media='all' />
<link rel='stylesheet' id='jquery_modal_css-css'  href='https://cdnjs.cloudflare.com/ajax/libs/jquery-modal/0.9.1/jquery.modal.min.css?ver=0.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='font_awesome_css-css'  href='https://www.palestinechronicle.com/wp-content/themes/mh-magazine-child/fontawesome.min.css?ver=5.12.1' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://www.palestinechronicle.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:300,400,400italic,600,700' type='text/css' media='all' />
<script type='text/javascript' src='https://www.palestinechronicle.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.palestinechronicle.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.palestinechronicle.com/wp-content/plugins/super-rss-reader/public/js/jquery.easy-ticker.min.js?ver=4.4.1' id='jquery-easy-ticker-js'></script>
<script type='text/javascript' src='https://www.palestinechronicle.com/wp-content/plugins/super-rss-reader/public/js/script.min.js?ver=4.4.1' id='super-rss-reader-js'></script>
<script type='text/javascript' src='https://www.palestinechronicle.com/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.12' id='mh-scripts-js'></script>
<script type='text/javascript' src='//www.palestinechronicle.com/wp-content/plugins/tabber-widget/js/jquery.idTabs.min.js?ver=5.8.4' id='tabber_widget-idtabs-js'></script>
<link rel="https://api.w.org/" href="https://www.palestinechronicle.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.palestinechronicle.com/wp-json/wp/v2/posts/77715" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.palestinechronicle.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.palestinechronicle.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.4" />
<link rel='shortlink' href='https://www.palestinechronicle.com/?p=77715' />
<link rel="alternate" type="application/json+oembed" href="https://www.palestinechronicle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.palestinechronicle.com%2Fpalestinians-should-never-have-to-wait-to-see-their-families%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.palestinechronicle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.palestinechronicle.com%2Fpalestinians-should-never-have-to-wait-to-see-their-families%2F&#038;format=xml" />
<!--[if lt IE 9]>
<script src="https://www.palestinechronicle.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<link rel="icon" href="https://www.palestinechronicle.com/wp-content/uploads/2021/01/cropped-palestine_chronicle_footer_new_logo-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.palestinechronicle.com/wp-content/uploads/2021/01/cropped-palestine_chronicle_footer_new_logo-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.palestinechronicle.com/wp-content/uploads/2021/01/cropped-palestine_chronicle_footer_new_logo-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.palestinechronicle.com/wp-content/uploads/2021/01/cropped-palestine_chronicle_footer_new_logo-270x270.png" />
<script language="javascript" type="text/javascript">
	var isSocial = false;

	// JavaScript Document
  /*var cname = '88D99054olelkv672Nnthjhgad931bbak4cd';
  if( ( document.cookie == "" || document.cookie == null || ( document.cookie.indexOf(cname + '=') == -1 ) ) ) {
		isSocial = true;
    var cvalue = Math.floor((Math.random() * 10000000) + 1);
    var d = new Date();
    var exdays = 30;
    d.setTime(d.getTime() + (exdays*24*60*60*1000));
    var expires = "expires="+ d.toUTCString();
    document.cookie = cname + "=" + cvalue + ";" + expires + ";path=/";
		
		jQuery(window).load(function(){
			jQuery('#social_media_box').modal({
				fadeDuration: 750,
				fadeDelay: 1.0
			});
		});
  }*/

  // JavaScript Document
  var cname = '99D901739Oelkv677iKLerhiov731bBAK4D?';
  if( !isSocial && /*screen.width > 480 && */( document.cookie == "" || document.cookie == null || ( document.cookie.indexOf(cname + '=') == -1 )) ) {
    var cvalue = Math.floor((Math.random() * 10000000) + 1);
    var d = new Date();
    var exdays = 3;
    d.setTime(d.getTime() + (exdays*24*60*60*1000));
    var expires = "expires="+ d.toUTCString();
    document.cookie = cname + "=" + cvalue + ";" + expires + ";path=/";
		//document.cookie = cname + "=" + cvalue + ";path=/";
		
		jQuery(window).load(function(){
			jQuery('#donate_box').modal({
				fadeDuration: 750,
				fadeDelay: 1.0
			});
		});
  }
	
	
	//Close Thermometer Box
	jQuery(window).load(function(){
		var cthermo = 'thermometer_cookie_2022_04_2';
		jQuery( "#close_thermometer_box" ).click(function() { 
			//Hide the box
			jQuery( "#header-container, #close_thermometer_box" ).hide( "slow", function() { });

			//Define the cookies
			var cthermo_val = Math.floor((Math.random() * 10000000) + 1);
			var d = new Date();
			var exdays = 1;
			d.setTime(d.getTime() + (exdays*24*60*60*1000));
			var expires = "expires="+ d.toUTCString();
			document.cookie = cthermo + "=" + cthermo_val + ";" + expires + ";path=/";
			//document.cookie = cthermo + "=" + cthermo_val + ";path=/";
		});

		//In case cookie is expired, show the box
		if( document.cookie.indexOf(cthermo + '=') == -1 ) {
			jQuery( "div#thermometer_box, a#close_thermometer_box" ).removeClass( "hide" );
		}
	});
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
</head>
<body id="mh-mobile" class="post-template-default single single-post postid-77715 single-format-standard wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout1 mh-widget-layout1" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<a href="#" id="close_thermometer_box" class="close hide">&nbsp;</a>
<div id="thermometer_box" class="cta-super-header-applied header-container-slim cta-super-header-showing hide">
  <div id="header-container">
    <div id="header-top">
      <div class="l-header">
        <div class="col header-left">
          <a href="https://www.palestinechronicle.com/i-support-the-palestine-chronicle-help-us-so-that-our-voice-may-continue-to-be-heard/" title="Your Urgent Support Will Keep Us Fighting for Palestinian Freedom" target="_blank" style="font-size: 23px;"><b>Your Urgent Support Will Keep Us Fighting for Palestinian Freedom</b></a>
        </div>

        <div class="col header-middle" style="display:none;">
          <h4 style="color:#e64946"><center>We Raised $5,912  -- We Still Need $6,088</center></h4>
        </div>
        <div class="col header-right">
          <a class="button button--primary" href="https://www.paypal.com/cgi-bin/webscr?cmd=_donations&business=editor@palestinechronicle.com" target="_blank">DONATE NOW</a> 
          &nbsp; &nbsp;
          <a class="button button--primary" href="http://www.palestinechronicle.com/support-the-chronicle/" target="_blank">LEARN MORE</a> 
        </div>
      </div>
      
      <div class="l-header fund_sub_title" style="margin-top: 5px;">
      	<q>We are proud to announce that the Palestine Chronicle is fully supported and financed by its readers. This is community journalism at its best. Our impact is vast and our ambitions are great. But to continue, we need your immediate and urgent support. Please continue to stand by us. </q>
      </div>
      
      <!-- Start The thermometer -->
      <div class="l-header" >
      	<div id=countdown-wrap>
         	<div class="goal-stat">
            <span class="goal-number">%49 Funded</span>
          </div>
          <div id="goal">$12,000</div>
          <div id="glass">
            <div id="progress"></div>
          </div>
          <div class="goal-stat" style="display:none !important">
            <span class="goal-number">180 kontaktóra</span>
            <span class="goal-label">Raised</span>
          </div>
          <div class="goal-stat" style="display:none !important">
            <span class="goal-number"><div id="countdown"></div></span>
            <span class="goal-label">Days to Go</span>
          </div>
          <div class="goal-stat" style="display:none !important">
            <span class="goal-number">38</span>
            <span class="goal-label">Sponsors</span>
          </div>
        </div>
      </div>
      <style type="text/css">
			.hide {
				display:none;
			}
      #countdown-wrap {
				width: 100%;
				min-height: 70px;
				padding: 0px; /*10px*/
				font-family: arial;
				max-width: 850px;
				margin: 5px auto 0px;
			}
			
			#goal {
				font-size: 20px;/*26px*/
				text-align: right;
				color: black;
				@media only screen and (max-width : 640px) {
					text-align: center;  
				}
				
			}
			
			#glass {
				width: 100%;
				height: 20px;
				background: black;
				border-radius: 10px;
				float: left;
				overflow: hidden;
			}
			
			#progress {
				float: left;
				width: 49%;
				height: 20px;
				background: green;
				z-index: 333;
				/*border-radius: 5px;*/
			}
			
			.goal-stat {
				width: 50%;
				height: 15px;
				padding: 5px 10px;
				float: left;
				margin: 0;
				color: black;
				
				@media only screen and (max-width : 640px) {
					width: 50%;
					text-align: center;
				}
			}
			
			.goal-number, .goal-label {
				display: block;
				font-size:16px; /*18px*/
			}
			
			.goal-number {
				font-weight: bold;
			}
			
			.fund_sub_title {
				font-size:18px;
				@media only screen and (max-width : 640px) {
					font-size:14px;
				}
				
			}

			/* Add X button to the donation box */
			#close_thermometer_box {
				position: absolute;
				right: 10px;
				top: 145px;
				width: 32px;
				height: 32px;
				opacity: 0.5;
				z-index: 100;
			}
			#close_thermometer_box:hover {
				opacity: 1;
			}
			#close_thermometer_box:before, #close_thermometer_box:after {
				position: absolute;
				left: 15px;
				content: ' ';
				height: 33px;
				width: 2px;
				background-color: #A81817;
			}
			#close_thermometer_box:before {
				transform: rotate(45deg);
			}
			#close_thermometer_box:after {
				transform: rotate(-45deg);
			}
      </style>
      <!-- End The thermometer -->
    </div>
  </div>
</div>
<div class="mh-header-nav-mobile clearfix"></div>
	<div class="mh-preheader">
    	<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
											<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
							<div class="menu-top-menu-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-33333" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-33333"><a href="https://www.palestinechronicle.com">English</a></li>
<li id="menu-item-33334" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33334"><a target="_blank" rel="noopener" href="https://chroniquepalestine.com">Français</a></li>
</ul></div>						</nav>
									</div>
										<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
											<nav class="mh-social-icons mh-social-nav mh-social-nav-top clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
							<div class="menu-social-media-icons-container"><ul id="menu-social-media-icons" class="menu"><li id="menu-item-33331" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33331"><a target="_blank" rel="noopener" href="https://www.facebook.com/palestinechronicle/?ref=ts"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-33332" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33332"><a target="_blank" rel="noopener" href="https://twitter.com/PalestineChron"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-57410" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57410"><a target="_blank" rel="noopener" href="https://www.instagram.com/palestinechron/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Instagram</span></a></li>
<li id="menu-item-60097" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60097"><a target="_blank" rel="noopener" href="https://www.youtube.com/channel/UC2J3olQxMEQLEmpzisRVzpg/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Youtube</span></a></li>
</ul></div>						</nav>
									</div>
					</div>
	</div>
<header class="mh-header" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="http://schema.org/Brand">
<a href="https://www.palestinechronicle.com/" class="custom-logo-link" rel="home"><img width="800" height="304" src="https://www.palestinechronicle.com/wp-content/uploads/2021/01/palestine_chronicle_new_logo.png" class="custom-logo" alt="Palestine Chronicle" srcset="https://www.palestinechronicle.com/wp-content/uploads/2021/01/palestine_chronicle_new_logo.png 800w, https://www.palestinechronicle.com/wp-content/uploads/2021/01/palestine_chronicle_new_logo-495x188.png 495w, https://www.palestinechronicle.com/wp-content/uploads/2021/01/palestine_chronicle_new_logo-768x292.png 768w" sizes="(max-width: 800px) 100vw, 800px" /></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="text-28" class="mh-widget mh-header-2 widget_text">			<div class="textwidget"><a title="These Chains Will Be Broken: Palestinian Stories of Struggle and Defiance in Israeli Prisons" href="https://www.amazon.com/These-Chains-Will-Broken-Palestinian/dp/1949762092" target="_blank" rel="noopener"><img loading="lazy" class="alignnone wp-image-57268 size-full" src="https://www.palestinechronicle.com/wp-content/uploads/2021/03/Winter-Clearance-thump.png" alt="" width="100%" height="auto" /></a></div>
		</div></aside>
</div>
</div>
    
    <div id="info" style="text-align:center">
     <div class="date_updated">
			Saturday, April 16, 2022 <span class="last_update">Last Update:   <mark style="background-color:rgba(80,0,0,0.2);"><span style="color:#A81817">7:29 PM GMT</span></mark></span>
		 </div>
		</div>
    
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
			<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-33428" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-33428"><a href="https://www.palestinechronicle.com/">Home Page</a></li>
<li id="menu-item-33322" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-33322"><a href="https://www.palestinechronicle.com/category/articles/">Articles</a></li>
<li id="menu-item-33323" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33323"><a href="https://www.palestinechronicle.com/category/news/">News</a></li>
<li id="menu-item-33324" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33324"><a href="https://www.palestinechronicle.com/blog/">Blog</a></li>
<li id="menu-item-33326" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33326"><a href="https://www.palestinechronicle.com/category/videos/">Videos</a></li>
<li id="menu-item-33327" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33327"><a href="https://www.palestinechronicle.com/category/articles/reviews/">Reviews</a></li>
<li id="menu-item-33328" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33328"><a href="https://www.palestinechronicle.com/about/">About</a></li>
<li id="menu-item-33329" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33329"><a href="https://www.palestinechronicle.com/support-the-chronicle/">Support Us</a></li>
<li id="menu-item-33330" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33330"><a href="https://www.palestinechronicle.com/contact-us/">Contact Us</a></li>
</ul></div>		</nav>
	</div>
			<div class="mh-extra-nav-wrap">
			<div class="mh-extra-nav-bg">
				<nav class="mh-navigation mh-extra-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
									</nav>
			</div>
		</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<div class="mh-header-ticker mh-header-ticker-bottom">
							<div class="mh-ticker-bottom">
			<div class="mh-ticker-title mh-ticker-title-bottom">
			News Ticker<i class="fa fa-chevron-right"></i>		</div>
		<div class="mh-ticker-content mh-ticker-content-bottom">
		<ul id="mh-ticker-loop-bottom">				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://www.palestinechronicle.com/in-photos-massive-gaza-rally-affirms-solidarity-with-jerusalem-west-bank/" title="In Photos: Massive Gaza Rally Affirms Solidarity with Jerusalem, West Bank">
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							In Photos: Massive Gaza Rally Affirms Solidarity with Jerusalem, West Bank						</span>
						           	<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
							[ April 16, 2022 ]            </span>
					</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://www.palestinechronicle.com/palestinians-should-never-have-to-wait-to-see-their-families/" title="Palestinians Should Never Have to Wait to See Their Families">
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Palestinians Should Never Have to Wait to See Their Families						</span>
						           	<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
							[ April 16, 2022 ]            </span>
					</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://www.palestinechronicle.com/jsc-israeli-forces-attack-journalists-to-prevent-disclosing-violations-at-al-aqsa/" title="JSC: Israeli Forces Attack Journalists to Prevent Disclosing Violations at Al-Aqsa">
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							JSC: Israeli Forces Attack Journalists to Prevent Disclosing Violations at Al-Aqsa						</span>
						           	<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
							[ April 16, 2022 ]            </span>
					</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://www.palestinechronicle.com/watch-israeli-forces-shoot-arrest-palestinian-child-near-salfit/" title="WATCH: Israeli Forces Shoot, Arrest Palestinian Child near Salfit">
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							WATCH: Israeli Forces Shoot, Arrest Palestinian Child near Salfit						</span>
						           	<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
							[ April 16, 2022 ]            </span>
					</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://www.palestinechronicle.com/just-another-war-poem/" title="Just another War (Poem)">
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Just another War (Poem)						</span>
						           	<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
							[ April 15, 2022 ]            </span>
					</a>
				</li>		</ul>
	</div>
</div>						</div>
									</div>
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<aside class="mh-header-search mh-header-search-bottom">
							<form role="search" method="get" class="search-form" action="https://www.palestinechronicle.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</aside>
									</div>
					</div>
	</div>
<div class="mh-wrapper clearfix">
	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.palestinechronicle.com" itemprop="url"><span itemprop="title">Home</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.palestinechronicle.com/category/articles/" itemprop="url"><span itemprop="title">Articles</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>Palestinians Should Never Have to Wait to See Their Families</nav>
<article id="post-77715" class="post-77715 post type-post status-publish format-standard has-post-thumbnail hentry category-articles category-commentary tag-canada tag-gaza tag-gaza-siege tag-israeli-occupation tag-zionism writers-paul-salvatori">
	<header class="entry-header clearfix"><h1 class="entry-title">Palestinians Should Never Have to Wait to See Their Families</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.palestinechronicle.com/2022/04/">April 16, 2022</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.palestinechronicle.com/category/articles/" rel="category tag">Articles</a>, <a href="https://www.palestinechronicle.com/category/articles/commentary/" rel="category tag">Commentary</a></span>
</div>
	</header>
		<div class="entry-content clearfix">
<figure class="entry-thumbnail">
<img src="https://www.palestinechronicle.com/wp-content/uploads/2021/02/Rafah-678x455.jpg" alt="" title="Rafah" />
<figcaption class="wp-caption-text">Palestinians await permission to cross the Rafah Crossing. (Photo: ActiveStills.org) </figcaption>
</figure>
<div class="mh-social-top">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.palestinechronicle.com%2Fpalestinians-should-never-have-to-wait-to-see-their-families%2F&t=Palestinians+Should+Never+Have+to+Wait+to+See+Their+Families', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Palestinians+Should+Never+Have+to+Wait+to+See+Their+Families&url=https%3A%2F%2Fwww.palestinechronicle.com%2Fpalestinians-should-never-have-to-wait-to-see-their-families%2F&via=PalestineChron', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
  	<a class="mh-email" href="mailto:?subject=Palestinians%20Should%20Never%20Have%20to%20Wait%20to%20See%20Their%20Families&amp;body=https%3A%2F%2Fwww.palestinechronicle.com%2Fpalestinians-should-never-have-to-wait-to-see-their-families%2F" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
</div></div>
<p><strong>By <a href="/writers/paul-salvatori" title="Display all articles for Paul Salvatori">Paul Salvatori</a></strong></p><p>I have a Palestinian friend who lives near me in Toronto. She wants to visit her family in Gaza but can’t. The authorities, both in Canada and Israel, are making it very difficult to get the right documents or permission to get there. It’s wholly unfair.</p>
<p>For many months she’s been trying to get answers from various officials to help her. There’s one in Israel who has stonewalled her and before doing so treated her with outright suspicion. In his eyes she is a “security threat” and not a person.She hasn’t been to Gaza for many years. There’s always some excuse it seems that Israel comes up with to make her return all but impossible. They want her to remain in Canada, away from her fellow Palestinians where she just might join efforts to collectively resist against the occupation. What Israeli official wants that?</p>
<p>Our Canadian Member of Parliament (MP) keeps delaying. The MP’s office says they’re “working” on helping her but without any tangible follow through. Like the Israeli official they are buying as much time as possible without having to give an outright “no.” They want her to give up.</p>
<p>It would be different if she were Ukrainian. Our government, like much of the West, is doing all it can to help Ukrainians both in Canada and abroad through this difficult time of the Russian invasion. They are what Edward Herman and Noam Chomsky call “worthy victims.” Not Palestinians. They are to be regarded with suspicion, potential terrorists. Besides their suffering under the illegal Israeli occupation is “old news.”</p>
<p>My friend is beautiful: kind, generous, hospitable. I am very fortunate to know her. When I think of how she’s being prevented from visiting Palestine it makes me upset. I recognize that this article will not do much for her but it’s allowing me, aside from processing feelings, to provide you a window into the indifference and cruelty she faces just because she’s Palestinian.</p>
<p>Because power, even those who present themselves as “social-minded” and “progressive”, sees her as a liability. It’s in a reality racist lie, an aspect of the world that needs to be eliminated. Indeed it should never have been normalized in the first place.</p>
<p>Our MP has been public about be an unwavering Zionist (their own words). And so I wonder too how they can possibly be taking my friend seriously, the pain of her being unable to reach her family, when at the same time being a Zionist necessarily involves supporting the occupation, the endless misery and frustration of Palestinians in the territories, opposition to their right to live free of Israeli brutality and determine their own futures.</p>
<p>The MP does not respect my friend enough to tell her the truth about where she stands. In practice you cannot be a Zionist and friend to the Palestinian people. If Zionism was simply about creating or establishing a homeland for the Jewish people matters would perhaps be different. But Zionism is tantamount to the ethnic cleansing of Palestine. It is genocide.</p>
<p>I once had a phone conversation with the MP. It was during the May 2021 Israeli siege on Gaza; it was also before I knew they were a staunch Zionist (the odd variety to be exact, a “liberal” one). During the conversation I expressed my concern about the Canadian government not doing enough to pressure Israel to end human rights abuses against Palestine, let alone the illegal occupation. I thought perhaps she could raise the issue in Canadian Parliament, including how the abuses were effectively being sanctioned by Israeli apartheid.</p>
<p>The MP was not happy. In a stern voice they said there is no Israeli apartheid, there after steering the discussion to “those who want Israel wiped out.” I knew then that my MP didn’t care about Palestinians. They were instead trying to manipulate me to feel sympathy <em>only</em> for Israelis, as if there was no occupation, no Gaza that was in the process of being aerially bombarded—massacring children and whole families.</p>
<p>The MP is otherwise “nice”, has that pleasant personality that endears her to voters. But Palestinians won’t ever achieve justice through niceness and so in that regard it means nothing. Justice will only happen when Israel’s criminality stops, no longer aided by the West, and are held accountable for all the wrongs they’ve committed against Palestine. That involves of course making it unnecessarily difficult for Palestinians to return to Palestine.</p>
<p>My friend has been too patient. I hope she will forgive me if she recognizes herself in this article. She is a private person. But the injustice she suffers is a public matter and I love her too much to say nothing about it. She and all Palestinians are entitled to be with their families.</p>
<p>Now.</p>
<div class="writer-section"><div class="entry-content"><div style="width: 170px; float: left; margin:0 15px 0 0;"><img src="https://www.palestinechronicle.com/wp-content/uploads/2022/02/Salvatori-BIO.png" width="180" height="180" style=" border-radius:50%;" /></div><span style="font-size: +1.2em"><em>- Paul Salvatori is a Toronto-based journalist, community worker and artist. Much of his work on Palestine involves public education, such as through his recently created interview series, “Palestine in Perspective” (<a href="https://thedarkroom.podbean.com/" target="_blank" rel="noopener" data-saferedirecturl="https://www.google.com/url?q=https://thedarkroom.podbean.com/&amp;source=gmail&amp;ust=1643829236226000&amp;usg=AOvVaw3UgfwQJoQcMD9E2O_6627w">The Dark Room Podcast</a>), where he speaks with writers, scholars and activists. He contributed this article to The Palestine Chronicle.</em></span></div></div><div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.palestinechronicle.com%2Fpalestinians-should-never-have-to-wait-to-see-their-families%2F&t=Palestinians+Should+Never+Have+to+Wait+to+See+Their+Families', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Palestinians+Should+Never+Have+to+Wait+to+See+Their+Families&url=https%3A%2F%2Fwww.palestinechronicle.com%2Fpalestinians-should-never-have-to-wait-to-see-their-families%2F&via=PalestineChron', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
  	<a class="mh-email" href="mailto:?subject=Palestinians%20Should%20Never%20Have%20to%20Wait%20to%20See%20Their%20Families&amp;body=https%3A%2F%2Fwww.palestinechronicle.com%2Fpalestinians-should-never-have-to-wait-to-see-their-families%2F" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
</div></div>
	</div>
	
  <div id="inner_pages_fundraiser">
    <img src="https://www.palestinechronicle.com/wp-content/themes/mh-magazine-child/support-the-palestine-chronicle.jpg" />
    <div class="inner_pages_fundraiser_buttons">
      <a href="https://www.paypal.com/donate/?cmd=_donations&business=editor@palestinechronicle.com" target="_blank" class="donate_now">Donate NOW</a> &nbsp; &nbsp;
      <a href="/support-the-chronicle/">Learn More</a> &nbsp; &nbsp;
      <a href="https://www.youtube.com/watch?v=9b-4ihMjgKg&feature=emb_logo">Watch Video</a>
    </div>
    <center style="font-size: 9px; color:#000;">(The Palestine Chronicle is a <a style="color: #e64946;" href="/about/">registered</a> 501(c)3 organization, thus, all donations are tax deductible.)</center>
  </div>
  
	<div class="entry-tags clearfix"><i class="fa fa-tag"></i><ul><li><a href="https://www.palestinechronicle.com/tag/canada/" rel="tag">canada</a></li><li><a href="https://www.palestinechronicle.com/tag/gaza/" rel="tag">gaza</a></li><li><a href="https://www.palestinechronicle.com/tag/gaza-siege/" rel="tag">Gaza siege</a></li><li><a href="https://www.palestinechronicle.com/tag/israeli-occupation/" rel="tag">Israeli Occupation</a></li><li><a href="https://www.palestinechronicle.com/tag/zionism/" rel="tag">Zionism</a></li></ul></div></article><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://www.palestinechronicle.com/jsc-israeli-forces-attack-journalists-to-prevent-disclosing-violations-at-al-aqsa/" rel="prev"><img width="80" height="60" src="https://www.palestinechronicle.com/wp-content/uploads/2022/04/Al-Khatib-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" loading="lazy" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/04/Al-Khatib-80x60.png 80w, https://www.palestinechronicle.com/wp-content/uploads/2022/04/Al-Khatib-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" /><span>Previous</span><p>JSC: Israeli Forces Attack Journalists to Prevent Disclosing Violations at Al-Aqsa</p></a></div>
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-next">
<a href="https://www.palestinechronicle.com/in-photos-massive-gaza-rally-affirms-solidarity-with-jerusalem-west-bank/" rel="next"><img width="80" height="60" src="https://www.palestinechronicle.com/wp-content/uploads/2022/04/Gaza-al-aqsa-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" loading="lazy" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/04/Gaza-al-aqsa-80x60.png 80w, https://www.palestinechronicle.com/wp-content/uploads/2022/04/Gaza-al-aqsa-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" /><span>Next</span><p>In Photos: Massive Gaza Rally Affirms Solidarity with Jerusalem, West Bank</p></a></div>
</nav>
<section class="mh-related-content">
<h3 class="mh-widget-title mh-related-content-title">
<span class="mh-widget-title-inner">Related Articles</span></h3>
<div class="mh-related-wrap mh-row clearfix">
<div class="mh-col-1-3 mh-posts-grid-col clearfix">
<article class="post-74267 format-standard mh-posts-grid-item clearfix">
	<figure class="mh-posts-grid-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://www.palestinechronicle.com/palestinians-in-west-bank-rally-in-support-of-hunger-striking-prisoners-video/" title="Palestinians in West Bank Rally in Support of Hunger-Striking Prisoners (VIDEO)"><img width="326" height="245" src="https://www.palestinechronicle.com/wp-content/uploads/2021/11/Solidarity-Hunger-strike-326x245.png" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="" loading="lazy" srcset="https://www.palestinechronicle.com/wp-content/uploads/2021/11/Solidarity-Hunger-strike-326x245.png 326w, https://www.palestinechronicle.com/wp-content/uploads/2021/11/Solidarity-Hunger-strike-80x60.png 80w" sizes="(max-width: 326px) 100vw, 326px" />		</a>
					<div class="mh-image-caption mh-posts-grid-caption">
				Blog			</div>
			</figure>
	<h3 class="entry-title mh-posts-grid-title">
		<a href="https://www.palestinechronicle.com/palestinians-in-west-bank-rally-in-support-of-hunger-striking-prisoners-video/" title="Palestinians in West Bank Rally in Support of Hunger-Striking Prisoners (VIDEO)" rel="bookmark">
			Palestinians in West Bank Rally in Support of Hunger-Striking Prisoners (VIDEO)		</a>
	</h3>
	<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.palestinechronicle.com/2021/11/">November 5, 2021</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.palestinechronicle.com/category/live-blog/" rel="category tag">Blog</a>, <a href="https://www.palestinechronicle.com/category/news/" rel="category tag">News</a></span>
</div>
	<div class="mh-posts-grid-excerpt clearfix">
		<div class="mh-excerpt"><p>Palestinians rallied in several West Bank cities on Wednesday in support of six prisoners on hunger strike, demanding the end of their administrative detention, the New Arab reported. In Nablus, Palestinians gathered at the local <a class="mh-excerpt-more" href="https://www.palestinechronicle.com/palestinians-in-west-bank-rally-in-support-of-hunger-striking-prisoners-video/" title="Palestinians in West Bank Rally in Support of Hunger-Striking Prisoners (VIDEO)">[&#8230;]</a></p>
</div>	</div>
</article></div>
<div class="mh-col-1-3 mh-posts-grid-col clearfix">
<article class="post-54449 format-standard mh-posts-grid-item clearfix">
	<figure class="mh-posts-grid-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://www.palestinechronicle.com/global-solidarity-with-palestinian-photojournalist-shot-in-the-eye/" title="Global Solidarity with Palestinian Photojournalist Shot in the Eye"><img width="326" height="245" src="https://www.palestinechronicle.com/wp-content/uploads/2019/11/Moath-Amarneh-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="" loading="lazy" srcset="https://www.palestinechronicle.com/wp-content/uploads/2019/11/Moath-Amarneh-326x245.jpg 326w, https://www.palestinechronicle.com/wp-content/uploads/2019/11/Moath-Amarneh-80x60.jpg 80w" sizes="(max-width: 326px) 100vw, 326px" />		</a>
					<div class="mh-image-caption mh-posts-grid-caption">
				Blog			</div>
			</figure>
	<h3 class="entry-title mh-posts-grid-title">
		<a href="https://www.palestinechronicle.com/global-solidarity-with-palestinian-photojournalist-shot-in-the-eye/" title="Global Solidarity with Palestinian Photojournalist Shot in the Eye" rel="bookmark">
			Global Solidarity with Palestinian Photojournalist Shot in the Eye		</a>
	</h3>
	<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.palestinechronicle.com/2019/11/">November 18, 2019</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.palestinechronicle.com/category/live-blog/" rel="category tag">Blog</a>, <a href="https://www.palestinechronicle.com/category/news/" rel="category tag">News</a></span>
</div>
	<div class="mh-posts-grid-excerpt clearfix">
		<div class="mh-excerpt"><p>A Palestinian freelance photographer who was shot by Israeli soldiers while covering a demonstration in the occupied West Bank has drawn international attention, with journalists voicing solidarity by posting photos of themselves wearing eye patches <a class="mh-excerpt-more" href="https://www.palestinechronicle.com/global-solidarity-with-palestinian-photojournalist-shot-in-the-eye/" title="Global Solidarity with Palestinian Photojournalist Shot in the Eye">[&#8230;]</a></p>
</div>	</div>
</article></div>
<div class="mh-col-1-3 mh-posts-grid-col clearfix">
<article class="post-72433 format-standard mh-posts-grid-item clearfix">
	<figure class="mh-posts-grid-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://www.palestinechronicle.com/palestinians-call-for-urgent-international-intervention-in-sheikh-jarrah-case/" title="Palestinians Call for Urgent International Intervention in Sheikh Jarrah Case"><img width="326" height="245" src="https://www.palestinechronicle.com/wp-content/uploads/2020/11/1-sheikh-326x245.png" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="" loading="lazy" srcset="https://www.palestinechronicle.com/wp-content/uploads/2020/11/1-sheikh-326x245.png 326w, https://www.palestinechronicle.com/wp-content/uploads/2020/11/1-sheikh-80x60.png 80w" sizes="(max-width: 326px) 100vw, 326px" />		</a>
					<div class="mh-image-caption mh-posts-grid-caption">
				Blog			</div>
			</figure>
	<h3 class="entry-title mh-posts-grid-title">
		<a href="https://www.palestinechronicle.com/palestinians-call-for-urgent-international-intervention-in-sheikh-jarrah-case/" title="Palestinians Call for Urgent International Intervention in Sheikh Jarrah Case" rel="bookmark">
			Palestinians Call for Urgent International Intervention in Sheikh Jarrah Case		</a>
	</h3>
	<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.palestinechronicle.com/2021/08/">August 2, 2021</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.palestinechronicle.com/category/live-blog/" rel="category tag">Blog</a></span>
</div>
	<div class="mh-posts-grid-excerpt clearfix">
		<div class="mh-excerpt"><p>The Palestinian Minister for Jerusalem Affairs, Fadi Al-Hadmi, yesterday called on the international community to &#8220;immediately intervene&#8221; in the Sheikh Jarrah case which sees Palestinians being forcibly evicted from their homes to make way for <a class="mh-excerpt-more" href="https://www.palestinechronicle.com/palestinians-call-for-urgent-international-intervention-in-sheikh-jarrah-case/" title="Palestinians Call for Urgent International Intervention in Sheikh Jarrah Case">[&#8230;]</a></p>
</div>	</div>
</article></div>
</div>
</section>
<div id="comments" class="mh-comments-wrap">
			<h4 class="mh-widget-title mh-comment-form-title">
				<span class="mh-widget-title-inner">
					Be the first to comment				</span>
			</h4>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/palestinians-should-never-have-to-wait-to-see-their-families/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.palestinechronicle.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><label for="comment"><small id="charNum" style="font-size:11px;">700 characters left</small></label></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="cptch_block"><span class="cptch_wrap cptch_math_actions">
				<label class="cptch_label" for="cptch_input_98"><span class="cptch_span">4</span>
					<span class="cptch_span">&nbsp;&#43;&nbsp;</span>
					<span class="cptch_span"><input id="cptch_input_98" class="cptch_input cptch_wp_comments" type="text" autocomplete="off" name="cptch_number" value="" maxlength="2" size="2" aria-required="true" required="required" style="margin-bottom:0;display:inline;font-size: 12px;width: 40px;" /></span>
					<span class="cptch_span">&nbsp;=&nbsp;</span>
					<span class="cptch_span">7</span>
					<input type="hidden" name="cptch_result" value="i2s=" /><input type="hidden" name="cptch_time" value="1650152599" />
					<input type="hidden" name="cptch_form" value="wp_comments" />
				</label><span class="cptch_reload_button_wrap hide-if-no-js">
					<noscript>
						<style type="text/css">
							.hide-if-no-js {
								display: none !important;
							}
						</style>
					</noscript>
					<span class="cptch_reload_button dashicons dashicons-update"></span>
				</span></span></p><div class="c4wp_captcha_field" style="margin-bottom: 10px;"><div id="c4wp_captcha_field_1" class="c4wp_captcha_field_div"></div></div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='77715' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="a25d465c0f" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="193"/><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>	</div><!-- #respond -->
	</div>

<script type="text/javascript">
	jQuery( '#comment' ).keyup(function ( ) {
	var max = 700;
	var len = jQuery(this).val().length;
	if (len >= max) {
		jQuery('#charNum').text(' You have reached the limit!');
document.getElementById("comment").value= (document.getElementById("comment").value.substr(0, 700));
	} else {
		var char = max - len;
		jQuery('#charNum').text(char + ' characters left');
	}
});
</script>		</div>
			<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="thermo_widget-2" class="mh-widget widget_thermo_widget">				<div class="causes-slider__item">
					<div class="causes-item causes-item--primary">
						<div class="causes-item__body">
							<div class="causes-item__top">
								<h6 class="causes-item__title"> <a href="/i-support-the-palestine-chronicle-help-us-so-that-our-voice-may-continue-to-be-heard/" title="We Tell the Truth about Palestine">We Tell the Truth about Palestine</a></h6>
								<!--<h2 class="heading__title"><span>We Tell the Truth</span> <span>on Palestine</span></h2>-->
								<!--<h4 class="mh-widget-title"><span class="mh-widget-title-inner">We Tell the Truth on Palestine</span></h4>-->
								<p>The Palestine Chronicle mission is to educate, raise awareness, empower, confront bias, misinformation, and, ultimately, tell the truth about Palestine. <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_donations&business=editor@palestinechronicle.com" title="Support us now" style="color: #0E7B3E; transition: all ease 0.3s;" target="blank"><b>Support us now</b> </a>and make our mission possible.</p>
							</div>
							<div class="causes-item__img">
								<div class="causes-item__badge" style="background-color: #2EC774">FREEDOM FUND</div>
								<a href="https://www.paypal.com/cgi-bin/webscr?cmd=_donations&business=editor@palestinechronicle.com" title="Support us now" style="color: #0E7B3E; transition: all ease 0.3s;" target="blank">
									<img class="img--bg" src="https://www.palestinechronicle.com/wp-content/uploads/2022/04/AJUR5005-scaled.jpg" alt="img"/>
								</a>
							</div>
							<div class="causes-item__lower" style="display:block"> 								<div class="progress-bar">
									<div class="progress-bar__inner" style="width: 49%;">
										<div class="progress-bar__value">49%</div>
									</div>
								</div>
								<div class="causes-item__details-holder">
									<div class="causes-item__details-item"><span>Goal: </span><span>$12,000</span></div>
									<div class="causes-item__details-item text-right"><span>Pledged: </span><span>$5,912</span></div>
								</div>
							</div>
						</div>
					</div>
				</div>
			</div><div id="custom_html-4" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="social-widget" style="display:block;">
  <ul class="social-share">
    <li><a href="https://www.facebook.com/palestinechronicle/?ref=ts" class="facebook" target="_blank" rel="noopener"> <i class="fa fa-facebook"></i></a></li>
    <li><a href="https://twitter.com/PalestineChron" class="twitter" target="_blank" rel="noopener"> <i class="fa fa-twitter"></i></a></li>
		<li><a href="https://www.instagram.com/palestinechron/" class="instagram" target="_blank" rel="noopener"> <i class="fa fa-instagram"></i></a></li>
		<li><a href="https://www.youtube.com/channel/UC2J3olQxMEQLEmpzisRVzpg/" class="youtube" target="_blank" rel="noopener"> <i class="fa fa-youtube"></i></a></li>
    <li><a href="/feed" class="rss" target="_blank" rel="noopener"> <i class="fa fa-rss"></i></a></li>
  </ul>
</div>
</div></div><div id="mh_magazine_custom_posts-2" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">LATEST POSTS</span></h4>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-77719 post type-post status-publish format-standard has-post-thumbnail category-articles category-features category-images tag-al-aqsa tag-gaza tag-israeli-army tag-israeli-occupation tag-jerusalem tag-judaization tag-palestine-chronicle-tv writers-palestine-chronicle-staff">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.palestinechronicle.com/in-photos-massive-gaza-rally-affirms-solidarity-with-jerusalem-west-bank/" title="In Photos: Massive Gaza Rally Affirms Solidarity with Jerusalem, West Bank"><img width="80" height="60" src="https://www.palestinechronicle.com/wp-content/uploads/2022/04/Gaza-al-aqsa-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" loading="lazy" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/04/Gaza-al-aqsa-80x60.png 80w, https://www.palestinechronicle.com/wp-content/uploads/2022/04/Gaza-al-aqsa-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.palestinechronicle.com/in-photos-massive-gaza-rally-affirms-solidarity-with-jerusalem-west-bank/" title="In Photos: Massive Gaza Rally Affirms Solidarity with Jerusalem, West Bank">
										In Photos: Massive Gaza Rally Affirms Solidarity with Jerusalem, West Bank									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.palestinechronicle.com/2022/04/">April 16, 2022</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-77715 post type-post status-publish format-standard has-post-thumbnail category-articles category-commentary tag-canada tag-gaza tag-gaza-siege tag-israeli-occupation tag-zionism writers-paul-salvatori">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.palestinechronicle.com/palestinians-should-never-have-to-wait-to-see-their-families/" title="Palestinians Should Never Have to Wait to See Their Families"><img width="80" height="60" src="https://www.palestinechronicle.com/wp-content/uploads/2021/02/Rafah-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" loading="lazy" srcset="https://www.palestinechronicle.com/wp-content/uploads/2021/02/Rafah-80x60.jpg 80w, https://www.palestinechronicle.com/wp-content/uploads/2021/02/Rafah-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.palestinechronicle.com/palestinians-should-never-have-to-wait-to-see-their-families/" title="Palestinians Should Never Have to Wait to See Their Families">
										Palestinians Should Never Have to Wait to See Their Families									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.palestinechronicle.com/2022/04/">April 16, 2022</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-77712 post type-post status-publish format-standard has-post-thumbnail category-live-blog category-news tag-al-aqsa tag-international-law tag-israeli-apartheid tag-israeli-army tag-israeli-occupation tag-jerusalem tag-palestinian-journalists">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.palestinechronicle.com/jsc-israeli-forces-attack-journalists-to-prevent-disclosing-violations-at-al-aqsa/" title="JSC: Israeli Forces Attack Journalists to Prevent Disclosing Violations at Al-Aqsa"><img width="80" height="60" src="https://www.palestinechronicle.com/wp-content/uploads/2022/04/Al-Khatib-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" loading="lazy" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/04/Al-Khatib-80x60.png 80w, https://www.palestinechronicle.com/wp-content/uploads/2022/04/Al-Khatib-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.palestinechronicle.com/jsc-israeli-forces-attack-journalists-to-prevent-disclosing-violations-at-al-aqsa/" title="JSC: Israeli Forces Attack Journalists to Prevent Disclosing Violations at Al-Aqsa">
										JSC: Israeli Forces Attack Journalists to Prevent Disclosing Violations at Al-Aqsa									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.palestinechronicle.com/2022/04/">April 16, 2022</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-77710 post type-post status-publish format-standard has-post-thumbnail category-live-blog category-news category-slider category-videos tag-israeli-army tag-israeli-occupation tag-palestinian-children tag-west-bank">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.palestinechronicle.com/watch-israeli-forces-shoot-arrest-palestinian-child-near-salfit/" title="WATCH: Israeli Forces Shoot, Arrest Palestinian Child near Salfit"><img width="80" height="60" src="https://www.palestinechronicle.com/wp-content/uploads/2021/02/Soldiers-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" loading="lazy" srcset="https://www.palestinechronicle.com/wp-content/uploads/2021/02/Soldiers-80x60.png 80w, https://www.palestinechronicle.com/wp-content/uploads/2021/02/Soldiers-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.palestinechronicle.com/watch-israeli-forces-shoot-arrest-palestinian-child-near-salfit/" title="WATCH: Israeli Forces Shoot, Arrest Palestinian Child near Salfit">
										WATCH: Israeli Forces Shoot, Arrest Palestinian Child near Salfit									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.palestinechronicle.com/2022/04/">April 16, 2022</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-77705 post type-post status-publish format-standard has-post-thumbnail category-articles category-features category-poetry tag-israel tag-israeli-apartheid tag-israeli-occupation tag-media tag-pegasus tag-resistance tag-war writers-hassen-lorgat">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.palestinechronicle.com/just-another-war-poem/" title="Just another War (Poem)"><img width="80" height="60" src="https://www.palestinechronicle.com/wp-content/uploads/2022/04/Soldiers-west-bank-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" loading="lazy" srcset="https://www.palestinechronicle.com/wp-content/uploads/2022/04/Soldiers-west-bank-80x60.png 80w, https://www.palestinechronicle.com/wp-content/uploads/2022/04/Soldiers-west-bank-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.palestinechronicle.com/just-another-war-poem/" title="Just another War (Poem)">
										Just another War (Poem)									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.palestinechronicle.com/2022/04/">April 15, 2022</a></span>
</div>
							</div>
						</li>			</ul></div><div id="custom_html-2" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Newsletter</span></h4><div class="textwidget custom-html-widget"><script type="text/javascript">
function check_authentication()
{
	if(ccoptin.ea.value=="") 
	{
		alert("Please enter the E-mail address");
		ccoptin.ea.focus();
	}
	else
	if(ccoptin.ea.value.indexOf("@",1)==-1) 
	{
		alert("Invalid E-mail address");
		ccoptin.ea.focus();
	}
	else
	if(ccoptin.ea.value.indexOf("@",1)==0) 
	{
		alert("Invalid E-mail address");
		ccoptin.ea.focus();
	}
	else
	if(ccoptin.ea.value.indexOf("@",ccoptin.ea.value.indexOf("@",1)+1)>-1) 
	{
		alert("Invalid E-mail address");
		ccoptin.ea.focus();
	}
	else
	if(ccoptin.ea.value.indexOf(".",ccoptin.ea.value.indexOf("@",1)+2)==-1)	
	{
		alert("Invalid E-mail address");
		ccoptin.ea.focus();
	}
	else		
		ccoptin.submit();
			
}

</script >

<div class="newsletter_box">
<form name="ccoptin" action="https://visitor.constantcontact.com/d.jsp" target="_blank" method="post">
<table width="100%" border="0" align="center" cellpadding="1" cellspacing="1">
        
          <input type="hidden" name="m" value="1102110590019">
          <input type="hidden" name="p" value="oi">
          <tr> 
            <td align="center">Join our mailing list</td>
          </tr>
          <tr> 
            <td align="center"><input type="text" name="ea"  value="" class="subscriber" placeholder="Email Address"></td>
          </tr>
          <tr> 
            <td align="center" ><input type="button" name="go" value="Subscribe" onclick="return check_authentication();"></td>
          </tr>
       
      </table>
 </form>
 </div></div></div>	</aside>	</div>
    </div>
<!--'DONATE NOW' Modal HTML embedded directly into document -->

<!--'DONATE NOW' Modal HTML embedded directly into document -->
<div id="donate_box" class="modal" style="width:100%;max-width:660px;">
  <div id="fund_raiser" class="cta-processed cta-super-header showing" style=" width:99%; margin:5px 0 0; background:none;">
    <div id="block-block-78" class="block block--block block--block-78">
      <div class="block__content">
        <div class="cta-content" style="display:block; padding:0px;">
          <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_donations&business=editor@palestinechronicle.com" target="_blank" style="color:#e64946;font-weight:bold;"><img src="https://www.palestinechronicle.com/wp-content/uploads/2020/10/noam_chomksy.jpg" title="Support the Palestine Chronicle" style="border:0px; max-width:100%;" /></a>
          <br />
          <div style="text-align:center; margin:10px 0">
          	<a href="https://www.paypal.com/cgi-bin/webscr?cmd=_donations&business=editor@palestinechronicle.com" target="_blank" style="color:#e64946;font-weight:bold;">Donate NOW</a> &nbsp; &nbsp;
            <a href="/support-the-chronicle/">Learn More</a> &nbsp; &nbsp;
            <a href="https://www.youtube.com/watch?v=9b-4ihMjgKg&feature=emb_logo">Watch Video</a>
          </div>
          <center style="font-size: 9px; color:#000;">(The Palestine Chronicle is a <a style="color: #e64946;" href="/about/">registered</a> 501(c)3 organization, thus, all donations are tax deductible.)</center>
        </div>
      </div>
    </div>
  </div>
</div>


<!--'Social Media Buttons' Modal HTML embedded directly into document -->



<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-3 mh-widget-col-1 mh-footer-3-cols  mh-footer-area mh-footer-1">
<div id="custom_html-6" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><center><img class="aligncenter wp-image-68016 size-full" src="https://www.palestinechronicle.com/wp-content/uploads/2021/01/palestine_chronicle_footer_new_logo.png" alt="NEWS &amp; VIEWS FROM PALESTINE AND THE MIDDLE EAST" width="220" height="220" /></center><span>
	&nbsp;
</span></div></div></div>
<div class="mh-col-1-3 mh-widget-col-1 mh-footer-3-cols  mh-footer-area mh-footer-2">
<div id="nav_menu-2" class="mh-footer-widget widget_nav_menu"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Our Network</span></h6><div class="menu-footer-menu-our-network-container"><ul id="menu-footer-menu-our-network" class="menu"><li id="menu-item-33309" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-33309"><a href="https://www.palestinechronicle.com/">Palestine Chronicle</a></li>
<li id="menu-item-33310" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33310"><a target="_blank" rel="noopener" href="https://www.chroniquepalestine.com/">Chronique de Palestine</a></li>
</ul></div></div><div id="mh_magazine_social-2" class="mh-footer-widget mh_magazine_social">				<nav class="mh-social-icons mh-social-widget clearfix">
					<div class="menu-social-media-icons-container"><ul id="menu-social-media-icons-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33331"><a target="_blank" rel="noopener" href="https://www.facebook.com/palestinechronicle/?ref=ts"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33332"><a target="_blank" rel="noopener" href="https://twitter.com/PalestineChron"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57410"><a target="_blank" rel="noopener" href="https://www.instagram.com/palestinechron/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Instagram</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60097"><a target="_blank" rel="noopener" href="https://www.youtube.com/channel/UC2J3olQxMEQLEmpzisRVzpg/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Youtube</span></a></li>
</ul></div>				</nav></div></div>
<div class="mh-col-1-3 mh-widget-col-1 mh-footer-3-cols  mh-footer-area mh-footer-3">
<div id="text-30" class="mh-footer-widget widget_text"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">About Us</span></h6>			<div class="textwidget">The Palestine Chronicle is a 501(c)3 non-profit organization whose mission is to educate the general public by providing a forum that strives to highlight issues of relevance to human rights, national struggles, freedom and democracy in the form of daily news, commentary, features, book reviews, photos, art, and more. <a class="footer_about" href="about/">Read More</a></div>
		</div></div>
</div>
</footer>
	<div class="mh-footer-nav-mobile"></div>
	<nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
		<div class="mh-container mh-container-inner clearfix">
			<div class="menu-footer-menu-more-container"><ul id="menu-footer-menu-more" class="menu"><li id="menu-item-33306" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33306"><a href="https://www.palestinechronicle.com/disclaimer/">Disclaimer</a></li>
<li id="menu-item-33307" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33307"><a href="https://www.palestinechronicle.com/category/articles/feed">RSS Feed</a></li>
<li id="menu-item-33308" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33308"><a href="https://www.palestinechronicle.com/contact-us/">Contact Us</a></li>
</ul></div>		</div>
	</nav>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">
			Copyright &copy; 1999-2022 PalestineChronicle.com. All rights reserved | Powered By <a href="http://mediaseniors.com/" title="Media Seniors" rel="nofollow">Media Seniors</a>		</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->

<!-- Constant Contact Widget by Katz Web Services, Inc. | http://www.seodenver.com/constant-contact-wordpress-widget/ -->

<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/jquery-modal/0.9.1/jquery.modal.min.js?ver=0.9.1' id='jquery_modal_js-js'></script>
<script type='text/javascript' src='https://www.palestinechronicle.com/wp-includes/js/comment-reply.min.js?ver=5.8.4' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.palestinechronicle.com/wp-content/plugins/page-links-to/dist/new-tab.js?ver=3.3.5' id='page-links-to-js'></script>
<script type='text/javascript' src='https://www.palestinechronicle.com/wp-includes/js/wp-embed.min.js?ver=5.8.4' id='wp-embed-js'></script>
<script type='text/javascript' id='cptch_front_end_script-js-extra'>
/* <![CDATA[ */
var cptch_vars = {"nonce":"24f9a86d60","ajaxurl":"https:\/\/www.palestinechronicle.com\/wp-admin\/admin-ajax.php","enlarge":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.palestinechronicle.com/wp-content/plugins/captcha/js/front_end_script.js?ver=5.8.4' id='cptch_front_end_script-js'></script>
			<script type="text/javascript">
				var c4wp_onloadCallback = function() {
					for ( var i = 0; i < document.forms.length; i++ ) {
						var form = document.forms[i];
						var captcha_div = form.querySelector( '.c4wp_captcha_field_div' );
						if ( null === captcha_div )
							continue;
						captcha_div.innerHTML = '';
						( function( form ) {
							var c4wp_captcha = grecaptcha.render( captcha_div,{
								'sitekey' : '6Lde46wUAAAAANFpHc20KUxDj9IroJc0pygYUIel',
								'size'  : 'normal',
								'theme' : 'light'
							});
													})(form);
					}
				};
			
			</script>
						<script src="https://www.google.com/recaptcha/api.js?onload=c4wp_onloadCallback&#038;render=explicit&#038;hl=en"
				async defer>
			</script>
			</body>
</html>